PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Gestion des erreurs
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Retourne :
  • en exécution : la liste des librairies (fichiers ".DLL") utilisées par l'application WINDEV, WINDEV Mobile ou par le site WEBDEV en cours. Seules les librairies en mémoire sont listées.
  • en mode test : toutes les librairies installées sur le poste en cours.
Exemple
// Récupération des librairies utilisées
ListeLibrairie est une chaîne = ListeDLL()
// Parcours de cette liste
Librairie est une chaîne
Librairie = ExtraitChaîne(ListeLibrairie, rangPremier, RC)
TANTQUE Librairie <> EOT
        // Récupération de la librairie
        Trace(ExtraitChaîne(Librairie, 1, TAB))
        // Librairie suivante
        Librairie = ExtraitChaîne(ListeLibrairie, rangSuivant, RC)
FIN
// Récupération des librairies utilisées
ListeLibrairie est une chaîne = ListeDLL()
// Parcours de cette liste
POUR TOUTE CHAÎNE CheminLibrairie DE ListeLibrairie SEPAREE PAR TAB + RC
// Récupération de la librairie
Trace(CheminLibrairie)
FIN
Syntaxe
<Résultat> = ListeDLL()
<Résultat> : Chaîne de caractères
Liste des librairies (fichiers ".DLL") utilisées par l'application en cours ou installées sur le poste en cours, sous la forme :
<1° librairie> + TAB + RC + <2° librairie> + TAB + RC + ...
+ <X librairie>
Où <X librairie> correspond au nom et chemin complet de la librairie X.
Remarques

Gestion des erreurs

La fonction ListeDLL ne retourne pas de code d'erreur. Pour savoir si cette fonction a généré une erreur, utilisez la variable ErreurDétectée. En cas d'erreur, il est possible de connaître le détail de l'erreur grâce à la fonction ErreurInfo.
Composante : wd240vm.dll
Version minimum requise
  • Version 10
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire