PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Suppression avec archivage
  • Gestion d'une suppression dans la base de données Palm
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
PalmSupprime (Fonction)
En anglais : PalmDelete
Avertissement
A partir de la version 16, cette fonctionnalité n'est plus disponible
Supprime l'enregistrement en cours dans une vue des enregistrements d'une base de données du Palm (créée avec PalmCharge). La suppression est directement effectuée dans la base de données sur le poste en cours.
Exemple
// Ouvre un accès nommé "ACCESJEF" sur la base de données PALM
// "Bloc-Notes" de l'utilisateur JEF
SI PalmCharge("ACCESJEF", "JEF") = Faux ALORS
        Erreur("Erreur lors de l'accès à la base de données PALM" + ...
        ErreurInfo())
        FinProgramme()
FIN
PalmFiltre(palmFCatégorie, "Vacances")
PalmLitPremier()
TANTQUE PalmEnDehors()=Faux
        SI PalmSupprime("ACCESJEF") = Faux ALORS
                Erreur("Erreur lors de la suppression de l'enregistrement" + ...
                       " dans la base de données PALM" + ErreurInfo())
        FIN
        PalmLitSuivant()
FIN
Syntaxe
<Résultat> = PalmSupprime([<Nom de l'accès> [, <Création de l'archive>]])
<Résultat> : Booléen
  • Vrai si l'enregistrement a été supprimé,
  • Faux dans le cas contraire. Pour plus de détails sur l'erreur, utilisez la fonction ErreurInfo.
<Nom de l'accès> : Chaîne de caractères optionnelle avec guillemets
Nom de l'accès précédemment défini grâce à la fonction PalmCharge. Si ce paramètre n'est pas précisé, le dernier accès manipulé par une fonction PALM est utilisé.
<Création de l'archive> : Booléen optionnel
  • Vrai pour supprimer l'enregistrement et archiver l'enregistrement dans un fichier d'archive. Ce fichier d'archive pourra être manipulé avec "Palm Desktop".
  • Faux (valeur par défaut) pour supprimer directement l'enregistrement (sans créer une archive de l'enregistrement).
Remarques

Suppression avec archivage

Si la suppression de l'enregistrement "MonMémo" dans la catégorie "PCS" est réalisée avec archivage, l'enregistrement "MonMémo" sera copié dans un fichier nommé PCS.MPA.
Un fichier d'archive est créé par catégorie d'enregistrement supprimé.

Gestion d'une suppression dans la base de données Palm

Conseil : Avant la modification de la base de données, il est conseillé de faire une copie de sauvegarde de la base de données (à l'aide de la fonction fCopieFichier par exemple). Une copie de sauvegarde est automatiquement réalisée avant la synchronisation (fichier memodat.bak).
Remarque : Pendant l'exécution de l'application WINDEV, il est possible de :
  • synchroniser le Palm
  • lancer et utiliser Palm Desktop. Attention : si des modifications sont réalisées dans Palm Desktop, il sera nécessaire de mettre à jour les données de l'application WINDEV avec la fonction PalmRafraichit.
Si l'application WINDEV a modifié la base de données, l'application Palm Desktop est automatiquement avertie de cette modification et se met à jour automatiquement. Le rafraîchissement des données modifiées par l'application WINDEV est réalisé en temps réel.
Composante : wd240plm.dll
Voir Aussi
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire