PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Avertissement
A partir de la version 16, cette fonctionnalité n'est plus disponible
Permet de savoir si l'enregistrement d'une base de données PALM sur lequel on veut se positionner est en dehors du fichier PALM ou du filtre.
Exemple
MonMémo est une chaîne // Chaîne contenant le message du bloc-notes
// Ouvre un accès nommé "ACCESJEF" sur la base de données PALM
// "Bloc-Notes" de l'utilisateur JEF
SI PalmCharge("ACCESJEF", "JEF") = Faux ALORS
Erreur("Erreur lors de l'accès à la base de données PALM" + ErreurInfo())
FinProgramme()
FIN
MonMémo = PalmLitDernier("ACCESJEF")
TANTQUE PalmEnDehors("ACCESJEF") = Faux
// Traitement
MonMémo = PalmLitPrécédent()
FIN
// Fermeture de l'accès
PalmFerme("ACCESJEF")
Syntaxe
<Résultat> = PalmEnDehors([<Nom de l'accès>])
<Résultat> : Booléen
  • Vrai en cas de tentative de positionnement sur un enregistrement situé en dehors du fichier PALM ou du filtre. Dans ce cas, l'enregistrement en cours correspond à celui qui était en cours avant l'opération de déplacement.
  • Faux si aucun problème n'a été détecté : l'enregistrement en cours appartient au fichier ou au filtre.
<Nom de l'accès> : Chaîne de caractères optionnelle (avec guillemets)
Nom de l'accès précédemment défini grâce à la fonction PalmCharge. Si ce paramètre n'est pas précisé, le dernier accès manipulé par une fonction PALM est utilisé.
Remarques
Les fonctions suivantes modifient la valeur retournée par PalmEnDehors :
Composante : wd240plm.dll
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire