PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

PV

WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget IOSApple WatchMac CatalystUniversal Windows 10 App
Autres
Procédures stockées
Renvoie la nation correspondant à une langue.
Exemple
// Connaître la nation correspondant
// à la langue arménienne
ResNation est un entier
ResNation = LangueVersNation(langueArménien)
SELON ResNation
CAS nationAllemand :
 ...
CAS nationAustralien :
 ...
CAS 0 :
 ...
FIN
// Connaître la nation correspondant
// à la langue anglaise en Australie
ResNation est un entier
ResNation = LangueVersNation(langueAnglais, 3)
SELON ResNation
CAS nationAnglais :
 ...
CAS nationAustralien :
 ...
CAS 0 :
 ...
FIN
Syntaxe
<Résultat> = LangueVersNation(<Langue> [, <Sous-langue>])
<Résultat> : Constante de type Entier
  • Nation correspondant de la langue spécifiée,
  • 0 si la langue spécifiée ne correspond à aucune nation.
Pour plus de détails sur ces constantes, consultez Correspondance entre les langues, les sous-langues, les alphabets et les nations.
<Langue> : Constante de type Entier
Langue dont on veut connaître la nation. Pour plus de détails sur ces constantes, consultez Correspondance entre les langues, les sous-langues, les alphabets et les nations.
<Sous-langue> : Entier optionnel
Sous-langue dont on veut connaître la nation. Pour plus de détails sur ces sous-langues, consultez Correspondance entre les langues, les sous-langues, les alphabets et les nations.
Si ce paramètre n'est pas spécifié, la nation standard de la <Langue> spécifiée est donnée.
Composante : wd280vm.dll
Version minimum requise
  • Version 10
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire