PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Arrête immédiatement l'impression de l'état en cours. Le code WLangage situé après l'appel à la fonction est exécuté. Cette fonction doit être utilisée dans un des traitements de l'état.
WINDEV Si l'état est imprimé dans le visualisateur de rapports, la fenêtre d'aperçu est automatiquement fermée.
Versions 15 et supérieures
WEBDEV - Code Serveur Cette fonction est disponible sous WEBDEV en code Serveur.
Nouveauté 15
WEBDEV - Code Serveur Cette fonction est disponible sous WEBDEV en code Serveur.
WEBDEV - Code Serveur Cette fonction est disponible sous WEBDEV en code Serveur.
Remarque : Cette fonction peut uniquement être utilisée dans les traitements des états créés avec l'éditeur d'états.
Versions 25 et supérieures
Android Cette fonction est désormais disponible pour les applications Android.
Nouveauté 25
Android Cette fonction est désormais disponible pour les applications Android.
Android Cette fonction est désormais disponible pour les applications Android.
Exemple
// Fin de l'impression
SI MoiMême..Source.NomClient = "MOULIN" ALORS
iFermeEtat()
FIN
Syntaxe
iFermeEtat()
Remarques
Pour ne pas exécuter le code WLangage présent après la fonction iFermeEtat, utilisez par exemple le mot-clé RETOUR.
Exemple :
SI TraitementFini() = Vrai ALORS
        iFermeEtat()
        RETOUR
FIN
Info("Coucou")
Classification Métier / UI : Code neutre
Composante : wd0etat.dll
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire