PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Force l'arrêt de l'impression d'un état. Le bas de page et le bloc de fin de document sont imprimés.
Remarque : Cette fonction peut uniquement être utilisée avec des états créés avec l'éditeur d'états.
Exemple
// Fin de l'impression si le fichier texte n'est pas trouvé
GLOBAL
// Identifiant du fichier texte
gfnIDFichier est un entier = 0

LOCAL
sFichierTexte est une chaîne = fRepEnCours() + "\Etats\Produit.txt"

// Ouvrir le fichier texte
gfnIDFichier = fOuvre(sFichierTexte, foLecture)
SI gfnIDFichier = -1 ALORS
Erreur(ErreurInfo())
iFinEtat() // Arrêter l'impression de l'état
FIN
// Fin de l'impression forcée lors de l'impression d'un enregistrement
SI MoiMême..Source.NomClient = "MOULIN" ALORS
        iFinEtat()
FIN
Syntaxe
iFinEtat()
Composante : wd240etat.dll
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire