PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

PV


WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget IOSApple WatchMac CatalystUniversal Windows 10 App
Autres
Procédures stockées
Identifie ou définit si une série est mise à jour à chaque dessin du graphe. Dans ce cas, à chaque appel de la fonction grDessine, le contenu de la série est automatiquement recalculé pour refléter les derniers changements de la source de données.
Exemple d'utilisation : une série dans un graphe sert de série de référence : cette série n'est pas mise à jour automatiquement.
Linux Attention : L'utilisation de cette fonction sous Linux nécessite une configuration spécifique. Pour plus de détails, consultez Les graphes.
Exemple
// Graphe créé par programmation
SI grMAJAutomatiqueSérie("MonGraphe", 5) = Vrai ALORS
grDessine("MonGraphe")
FIN
// Champ Graphe
SI grMAJAutomatiqueSérie(GRF_MonGraphe, 5) = Vrai ALORS
grDessine(GRF_MonGraphe)
FIN
Syntaxe

Identifie le mode de mise à jour de la série Masquer les détails

<Résultat> = grMAJAutomatiqueSérie(<Nom du graphe> , <Numéro de la série>)
<Résultat> : Booléen
Mode de mise à jour actuel de la série :
  • Vrai si la série est mise à jour automatiquement,
  • Faux dans le cas contraire.
<Nom du graphe> : Nom de champ ou chaîne de caractères
Nom du graphe à manipuler. Ce nom correspond :
  • soit au nom du graphe défini par programmation avec la fonction grCrée.
  • soit au nom du champ Graphe présent dans l'éditeur de fenêtres, de pages ou d'états.
Android Seuls les champs Graphe sont disponibles.
PHP Seuls les champs Graphe interactif sont disponibles.
<Numéro de la série> : Entier
Numéro de la série concernée.

Définit le mode de mise à jour de la série Masquer les détails

grMAJAutomatiqueSérie(<Nom du graphe> , <Numéro de la série> , <Mode de mise à jour>)
<Nom du graphe> : Nom de champ ou chaîne de caractères
Nom du graphe à manipuler. Ce nom correspond :
  • soit au nom du graphe défini par programmation avec la fonction grCrée.
  • soit au nom du champ Graphe présent dans l'éditeur de fenêtres, de pages ou d'états.
Android Seuls les champs Graphe sont disponibles.
PHP Seuls les champs Graphe interactif sont disponibles.
<Numéro de la série> : Entier
Numéro de la série concernée.
<Mode de mise à jour> : Booléen
  • Vrai si la série doit être mise à jour automatiquement,
  • Faux dans le cas contraire.
Remarques
La fonction grMAJAutomatiqueSérie est équivalente à la propriété MAJAutomatique.
Composante : wd280grf.dll
Version minimum requise
  • Version 10
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire