PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

PV

WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget IOSApple WatchMac CatalystUniversal Windows 10 App
Autres
Procédures stockées
EnumèreMenu (Fonction)
En anglais : EnumMenu
Renvoie :
  • le nom de la nième option ou sous-option du menu principal de la fenêtre.
  • le nom de la nième option ou sous-option d'un menu contextuel personnalisé (créé avec WINDEV ou WINDEV Mobile).
Utilisée dans une boucle, cette fonction permet d'énumérer les options de menu d'une fenêtre, comme les sous-options d'une option de menu.
iPhone/iPad Cette fonction permet uniquement d'énumérer les options d'un menu contextuel.
Exemple
i est un entier = 1
NomMenu est une chaîne
NomMenu = EnumèreMenu(MaFenêtre, 1) // Lecture du 1er menu de la fenêtre
TANTQUE NomMenu <> ""
Trace(NomMenu)
j est un entier = 1
NomSousMenu est une chaîne
NomSousMenu = EnumèreMenu(NomMenu, j) // Lecture de la 1ère option du menu
TANTQUE NomSousMenu <> ""
Trace(" " + NomSousMenu)
j++ // Option suivante
NomSousMenu = EnumèreMenu(NomMenu, j)
FIN
i++ // Menu suivant
NomMenu = EnumèreMenu(MaFenêtre, i)
FIN
Syntaxe
<Résultat> = EnumèreMenu(<Objet Parent> , <Numéro de l'option>)
<Résultat> : Chaîne de caractères
  • Nom de l'option,
  • Chaîne vide ("") si <Objet Parent> correspond à une option de menu ou si l'énumération est terminée.
Le nom de l'option a été défini sous l'éditeur de fenêtres lors de la création du menu.
<Objet Parent> : Chaîne de caractères
  • Nom de la fenêtre contenant les menus à lister. Cette fenêtre doit être ouverte lors de l'utilisation de cette fonction.
  • Nom du menu dont les options doivent être listées.
<Numéro de l'option> : Entier
Numéro de l'option dont le nom est recherché.
Remarques
Une erreur du WLangage est affichée dans les cas suivants :
  • <Numéro de l'option> est un entier négatif.
  • <Numéro de l'option> est supérieur au nombre d'options du menu + 1.
  • <Objet Parent> n'est ni une fenêtre, ni un menu, ni une option de menu.
  • <Objet Parent> est une fenêtre non ouverte. Pour lister un menu d'une fenêtre non ouverte, utilisez la fonction EnumèreSousElément.
Composante : wd280obj.dll
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire