PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE


  • Appels multiples de la fonction fDétecteStockageAmovible
  • Procédure locale à la fenêtre
  • Limitations
  • Equivalence
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
fDétecteStockageAmovible (Fonction)
En anglais : fDetectRemovableStorage
Détecte si une unité de stockage amovible (par exemple CD, clé USB, appareil photo USB, ...) a été ajoutée ou enlevée.
Exemple
SI fDétecteStockageAmovible("MaProcédure") = Faux ALORS
Erreur(ErreurInfo())
FIN
//----------------------------------------
PROCEDURE Maprocédure(Lettre, Action)
SI Action = StockageAmovibleInséré ALORS
Info(Lettre + ": Inséré")
SINON
Info(Lettre + ": Ejecté")
FIN
Syntaxe
<Résultat> = fDétecteStockageAmovible(<Nom de la procédure>)
<Résultat> : Booléen
  • Vrai si la détection a été effectuée.
  • Faux dans le cas contraire.
<Nom de la procédure> : Chaîne de caractères
  • Nom de la procédure WLangage à exécuter lors de la détection. Cette procédure est appelée à chaque fois qu'une unité de stockage est insérée ou éjectée.
  • Chaîne vide ("") pour désactiver la détection.
Cette procédure est de la forme :
PROCEDURE <Nom de la procédure>(<Lettre du lecteur>, <Type d'action>)
Le paramètre <Lettre du lecteur> est une chaîne permettant de connaître la lettre du lecteur associée à l'unité de stockage.
Le paramètre <Type d'action> est un entier permettant de savoir si le périphérique a été inséré ou éjecté. Ce paramètre peut prendre pour valeur :
StockageAmovibleInséréUne unité de stockage amovible a été insérée.
StockageAmovibleRetiréUne unité de stockage amovible a été éjectée.
Remarques

Appels multiples de la fonction fDétecteStockageAmovible

Si cette fonction est exécutée plusieurs fois avec des procédures différentes passées en paramètres, la dernière procédure utilisée remplacera toutes les procédures appelées auparavant : les premières procédures ne seront plus rappelées.

Procédure locale à la fenêtre

Si <Nom de la procédure> est une procédure locale à une fenêtre, la détection prendra fin lorsque la fenêtre sera fermée. Il est conseillé d'utiliser une procédure globale.

Limitations

La fonction fDétecteStockageAmovible ne doit pas être exécutée depuis un thread secondaire.

Equivalence

La fonction fDétecteStockageAmovible est équivalente à la fonction USBDétecteStockageAmovible.
Composante : wd240std.dll
Version minimum requise
  • Version 10
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire