PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Comment obtenir des informations sur l'erreur traitée ?
  • Exemple d'utilisation
  • Cas particulier
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
ErreurPropage (Fonction)
En anglais : ErrorPropagate
Propage une erreur non fatale qui pourra être traitée par le code appelant si ce code a activé une gestion des erreurs non fatales (sous l'éditeur de code, ou par la fonction ErreurChangeParamètre).
L'erreur est traitée par le niveau supérieur si :
  • le niveau supérieur a activé un traitement d'erreur.
  • l'erreur n'est pas gérée par un SI ... PAS ou par la variable ErreurDétectée.
Versions 18 et supérieures
Universal Windows 10 App Cette fonction est désormais disponible en mode Windows Store apps.
Nouveauté 18
Universal Windows 10 App Cette fonction est désormais disponible en mode Windows Store apps.
Universal Windows 10 App Cette fonction est désormais disponible en mode Windows Store apps.
Versions 21 et supérieures
Universal Windows 10 App Cette fonction est désormais disponible en mode Universal Windows 10 App.
Nouveauté 21
Universal Windows 10 App Cette fonction est désormais disponible en mode Universal Windows 10 App.
Universal Windows 10 App Cette fonction est désormais disponible en mode Universal Windows 10 App.
Syntaxe
ErreurPropage([<Message>])
<Message> : Chaîne de caractères optionnelle
Message supplémentaire pouvant être ajouté à l'erreur.
Remarques

Comment obtenir des informations sur l'erreur traitée ?

La fonction ErreurInfo permet de récupérer les informations de l'erreur.

Exemple d'utilisation

But : Encapsuler la fonction fOuvre dans une procédure tout en remontant l'erreur de la fonction fOuvre (si elle apparaît) :
PROCEDURE OuvreFichier(LOCAL sNomFichier est une chaîne)

fOuvre(sNomFichier)
SI ErreurDétectée = Vrai ALORS
        ErreurPropage()
        RETOUR                // ou RENVOYER
FIN
...
Il est ensuite possible d'appeler la procédure OuvreFichier :
...
OuvreFichier(sNomFichier)
SI ErreurDétectée = Vrai ALORS
       // traitement de l'erreur
FIN
Note : Il est bien sûr possible de faire l'équivalent avec les modes automatiques de gestion des erreurs.

Cas particulier

Le mécanisme de traitement de l'erreur, qu'il soit automatique (géré par la fenêtre de gestion des erreurs) ou par programmation (fonction ErreurChangeParamètre) ne se déclenche pas si la fonction WLangage ou la procédure utilisateur se trouve dans un des cas suivants :
SI PAS <Fonction ou procédure> ALORS
// traitement de l'erreur
FIN
<Fonction ou procédure>
SI ErreurDétectée = Vrai ALORS
// traitement de l'erreur
FIN
Le mécanisme considère alors que l'erreur est traitée par programmation et ne déclenche pas le traitement automatique.
Composante : wd240vm.dll
Version minimum requise
  • Version 10
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire