PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Principe d'utilisation
  • Étape 1 : Créer un compte utilisateur dans l'application de gestion des emails
  • Créer un compte
  • Étape 2 : Ouverture d'une session de messagerie
  • Exemple
  • Étape 3 : Envoi et réception d'emails
  • Envoi d'emails
  • Réception d'emails
  • Étape 4 : Fermeture de session
  • Exemple
  • Etape 5 : Synchroniser les emails avec le serveur d'emails
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget iOSApple WatchCatalystUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Principe d'utilisation
Pour envoyer ou lire des messages grâce aux comptes utilisateurs autres que le compte "ActiveSync" de Pocket Outlook, il faut :
  1. Décrire un compte utilisateur dans l'application de gestion des emails (Pocket Outlook par exemple).
  2. Se connecter depuis l'application WINDEV Mobile à l'application de gestion des emails (Pocket Outlook par exemple) grâce à la fonction EmailOuvreSession en utilisant une variable de type emailSessionOutlook (ou avec la fonction EmailOuvreSessionOutlook).
  3. Envoyer et recevoir les emails.
  4. Fermer la session avec l'application de gestion des emails (Pocket Outlook par exemple) grâce à la fonction EmailFermeSession.
  5. Synchroniser les emails avec le serveur d'emails.
Étape 1 : Créer un compte utilisateur dans l'application de gestion des emails
Le compte utilisateur permet de configurer l'application de gestion des emails (Pocket Outlook par exemple).
Dans le compte utilisateur sont définis :
  • les paramètres du protocole SMTP utilisé pour l'envoi des messages,
  • les paramètres du protocole POP3 ou IMAP utilisé pour la réception des messages,
  • les différents services de communication utilisés.
Remarque : Il est nécessaire de créer autant de comptes sur le poste qu'il y a d'utilisateurs ou de comptes emails différents. Le nom du compte sera ensuite utilisé pour ouvrir la session de messagerie.

Créer un compte

Pour créer un compte (sous Pocket Outlook par exemple) :
  1. Lancez Pocket Outlook (option "Démarrer .. Programmes .. Boîte de réception" par exemple).
  2. Sélectionnez l'option "Comptes .. Nouveau compte" (ou "Services .. Nouveau service").
  3. Répondez aux diverses questions posées.
  4. Donnez un nom au compte : ce nom sera utilisé dans les programmes WINDEV Mobile.
Étape 2 : Ouverture d'une session de messagerie
L'ouverture d'une session de messages peut être réalisée grâce à :
Remarque : Cette fonction doit être appelée avant toute autre fonction "email" dans votre application.

Exemple

Ouverture d'une session avec une variable de type emailSessionOutlook
PROCÉDURE OuvertureSession(NomDuCompte)

MaSession est un emailSessionOutlook
MaSession..Nom = NomDuCompte

EmailOuvreSession(MaSession)
SI ErreurDétectée = Vrai ALORS
Erreur("La session n'a pas pu être ouverte." + ...
"Erreur :" + RC + ErreurInfo(errMessage))
FIN
RENVOYER MaSession
Ouverture d'une session avec la fonction OuvreSessionOutlook
PROCEDURE OuvertureSession(NomDuCompte)

NumSession est un entier
NumSession = EmailOuvreSession(Compte)

SI NumSession = 0 ALORS
Erreur("La session n'a pas pu être ouverte." + ...
"Erreur :" + RC + ErreurInfo(errMessage))
FIN

RENVOYER NumSession
Étape 3 : Envoi et réception d'emails

Envoi d'emails

  • Si le Pocket PC est connecté à un poste PC, l'envoi d'emails est réalisé automatiquement dès que le Pocket PC est connecté à un poste PC disposant d'un accès à Internet.
  • Si le Pocket PC n'est pas connecté à un poste PC (le Pocket PC est donc équipé d'une carte Ethernet ou d'un modem GPRS), l'envoi d'emails est réalisé grâce à la fonction EmailEnvoieMessage : cette fonction permet de placer le message dans la boîte d'envoi de l'application de gestion des emails (boîte d'envoi de Pocket Outlook par exemple).
Pour plus de détails sur la création des emails, consultez Préparer l'envoi d'un email.
Exemple : Le code suivant permet d'envoyer tous les emails présents dans une table mémoire (table "TABLE_AENVOYER") par l'intermédiaire de Pocket Outlook. Chaque ligne de la ligne de la table correspond à un email.
Pour chaque email, les informations présentes dans la table mémoire sont transférées dans la structure email et l'email est envoyé. Le serveur d'emails est ensuite mis à jour.
I est un entier
POUR I = 1 _A_ TableOccurrence(TABLE_AENVOYER)
// Le courrier n'est envoyé qu'à une seule personne
Email.NbDestinataire = 1
Email.Destinataire[1] = ExtraitChaîne(TABLE_AENVOYER[I], 1)
// Sujet et message
Email.Sujet = ExtraitChaîne(TABLE_AENVOYER[I], 2)
Email.Message = ExtraitChaîne(TABLE_AENVOYER[I], 3)
// Pas de fichier attaché
Email.NbAttache = 0
// Envoi du message à Pocket Outlook
EmailEnvoieMessage(NumSession, Faux)
FIN

Réception d'emails

  • Si le Pocket PC est connecté à un poste PC, la réception d'emails est réalisée automatiquement dès que le Pocket PC est connecté à un poste PC disposant d'un accès à Internet.
  • Si le Pocket PC n'est pas connecté à un poste PC (le Pocket PC est donc équipé d'une carte Ethernet ou d'un modem GPRS), la réception d'emails est réalisée grâce aux fonctions de lecture des emails (fonctions EmailLitPremier, EmailLitSuivant, etc.) : ces fonctions permettent d'initialiser la structure email du WLangage avec les caractéristiques de l'email en cours de lecture (auteur de l'email, sujet, etc.).
Pour plus de détails sur la lecture d'emails, consultez Lire un email.
Exemple : Le code suivant permet de lire des emails. Les emails reçus sont stockés dans une table mémoire (table "TABLE_Messages"). La variable NumSession correspond à l'identifiant de la session. Dans cet exemple, les messages reçus sont supprimés de la boîte de réception et du serveur d'emails par la fonction EmailSupprimeMessage.
// Lecture du premier message non lu
SI EmailLitPremier(NumSession, "NON LUS") = Faux ALORS
Erreur("Erreur lors de la lecture du premier message")
FIN

// Parcours des messages non lus avec affichage dans une table mémoire
TableSupprimeTout(TABLE_Messages)
TANTQUE PAS Email.EnDehors
// La date de réception, l'adresse de l'expéditeur
// et le message sont affectés dans la table
TableAjoute(TABLE_Messages, Email.DateRéception + TAB + Email.AdresseExpéditeur + ...
TAB + Email.Message)
// Suppression du message
SI EmailSupprimeMessage(NumSession) = Faux ALORS
Erreur("Erreur lors de la suppression" + ...
"Le message n'a pas été supprimé")
FIN
// Lecture du message suivant non lu
SI EmailLitSuivant(NumSession,"NON LUS") = Faux ALORS
Erreur("Erreur lors de la lecture du message suivant")
FIN
FIN
Étape 4 : Fermeture de session
Lorsque la gestion des emails reçus et/ou envoyés est terminée, la fermeture de la session est réalisée avec la fonction EmailFermeSession. Cette fonction doit être la dernière fonction "email" utilisée.

Exemple

Le code suivant est une procédure permettant de fermer une session de messagerie. Dans ce code, la variable NumSession correspond à l'identifiant de session renvoyé par la fonction EmailOuvreSession.
PROCEDURE FermetureSession(NumSession)
// Fermeture de la session
EmailFermeSession(NumSession)
Etape 5 : Synchroniser les emails avec le serveur d'emails
Après avoir fermé la session de messages, il est nécessaire de synchroniser les emails avec le serveur d'emails. Pour cela, lancez si nécessaire Pocket Outlook et sélectionnez l'option "Service .. Se connecter".
Si le Pocket PC n'est pas équipé d'une carte Ethernet ou d'un modem GPRS, il est nécessaire de connecter le Pocket PC à un poste PC pour synchroniser réellement les emails.
Aucun paramétrage spécifique n'est nécessaire dans ActiveSync.
Version minimum requise
  • Version 9
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire