DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Présentation des protocoles POP3/SMTP
  • Les protocoles POP3 et SMTP
  • Principe d'utilisation
  • Envoi de messages en utilisant le protocole SMTP
  • Réception de messages en utilisant le protocole POP3
  • Remarques
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget IOSApple WatchMac CatalystUniversal Windows 10 App
Autres
Procédures stockées
Présentation des protocoles POP3/SMTP

Les protocoles POP3 et SMTP

  • Le protocole POP3 (Post Office Protocol) permet de recevoir des emails.
  • Le protocole SMTP (Simple Mail Transfer Protocol) permet d'envoyer des emails.
Remarques :
  • La réception des emails peut également être prise en charge en utilisant le protocole IMAP.
  • AndroidWidget AndroidiPhone/iPad Les connexions SSL sont gérées.
Principe d'utilisation

Envoi de messages en utilisant le protocole SMTP

Pour envoyer des messages en utilisant le protocole SMTP, il faut :
  1. Ouvrir une session SMTP :
  2. Construire le message à envoyer dans une variable de type Email ou dans la structure Email.
  3. Envoyer le message avec la fonction EmailEnvoieMessage.
  4. Fermer la session SMTP avec la fonction EmailFermeSession.

Réception de messages en utilisant le protocole POP3

Pour recevoir des emails en utilisant le protocole POP3, il faut :
  1. Ouvrir une session POP3 :Exemple d'ouverture de session en utilisant une variable de type emailSessionPOP3 :
    // Ouverture de la session de messagerie
    MaSession est un emailSessionPOP3
    MaSession.AdresseServeur = "pop.masociete.fr"
    MaSession.Nom = "utilisateur"
    MaSession.MotDePasse = "secret"
    EmailOuvreSession(MaSession)
  2. Lire les messages sur le serveur de messagerie :
    • avec la fonction EmailRécupèreTout,
    • avec une boucle de la forme :
      • Exemple utilisant une variable de type Email :
        MonMessage est un Email
        EmailLitPremier(MaSession, MonMessage)
        TANTQUE PAS MonMessage.EnDehors
        // Placer ici le traitement du message lu...
        ...
         
        EmailLitSuivant(MaSession, MonMessage)
        FIN
      • Exemple utilisant la structure Email :
        EmailLitPremier(MaSession)
        TANTQUE PAS Email.EnDehors
        // Placer ici le traitement du message lu...
        ...
         
        EmailLitSuivant(MaSession)
        FIN
    • ou avec une boucle de la forme :
      MonMessage est un Email
      POUR TOUT MonMessage DE MaSession
      // Placer ici le traitement du message lu...
      ...
      FIN
  3. Fermer la session POP3 avec la fonction EmailFermeSession.
Remarque : Il est possible d'ouvrir simultanément une session POP3 et une session SMTP avec la fonction EmailOuvreSession.
Remarques
Liste des exemples associés :
Les fonctions Email POP3 Exemples unitaires (WINDEV) : Les fonctions Email POP3
[ + ] Utilisation des fonctions Email pour gérer le protocole POP3.
Ce protocole sert à récupérer des emails depuis un serveur.
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire