PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Recherche de la chaîne de caractères
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget IOSApple WatchMac CatalystUniversal Windows 10 App
Autres
Procédures stockées
Recherche une chaîne de caractères dans un champ RTF (d'une fenêtre ou d'un état WINDEV) ou dans une chaîne de caractères contenant du texte au format RTF.
Exemple
// Passer tous les "WINDEV" d'un texte en rouge souligné
I est un entier
I = RTFRecherche(SAI_Saisie1, "WINDEV")
TANTQUE I > 0
// Passage en rouge
RTFSélection(SAI_Saisie1, rtfCouleur, RougeClair, I, 6)
// Passage en souligné
RTFSélection(SAI_Saisie1, rtfSouligné, Vrai, I, 6)
// Recherche du "WINDEV" suivant
I = RTFRecherche(SAI_Saisie1, "WINDEV", rtfSensibleCasse, I + 1)
FIN
nRes est un entier
sChaîne est une chaîne = SAI_Saisie1
// ****** UTILISE UNE VARIABLE DE TYPE CHAÎNE
// Recherche des mots contenant le mot "RTF"
nRes = RTFRecherche(sChaîne, "RTF", rtfMotComplet, 1)
TANTQUE nRes <> 0
nRes = RTFRecherche(sChaîne, "RTF", rtfMotComplet, nRes + 3)
FIN
Syntaxe
<Résultat> = RTFRecherche(<Champ ou chaîne RTF> , <Chaîne à rechercher> [, <Options> [, <Début>]])
<Résultat> : Entier
  • Position du premier caractère de la chaîne de caractères recherchée dans la chaîne initiale.
  • 0 si la chaîne recherchée n'a pas été trouvée.
Le formatage RTF est ignoré.
<Champ ou chaîne RTF> : Chaîne de caractères
Nom du champ RTF ou chaîne RTF dans lequel la recherche doit être effectuée.
<Chaîne à rechercher> : Chaîne de caractères
Chaîne de caractères à rechercher dans le champ ou dans la chaîne.
<Options> : Constante (ou combinaison de constantes) optionnelle
Indique les modalités de la recherche :
rtfSensibleCasseRecherche sensible à la casse.
rtfMotCompletSeuls les mots complets sont recherchés.
<Début> : Entier optionnel
Position du caractère à partir duquel la chaîne de caractères spécifiée est recherchée.
Si ce paramètre n'est pas spécifié, la recherche commence à la position du curseur (ou à la fin du texte sélectionné) et continue jusqu'à la fin du texte du champ ou de la chaîne.
Remarques

Recherche de la chaîne de caractères

  • Par défaut, la recherche ne prend pas en compte la casse des caractères et recherche tous les caractères spécifiés.
  • La recherche s'effectue à partir de la fin de la sélection (position du curseur de la souris) jusqu'à la fin du texte contenu dans le champ ou la chaîne.
Composante : wd270obj.dll
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire