DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Caractéristiques de la boîte de dialogue
  • Saut de ligne dans la boîte de dialogue
  • Divers
  • Application en arrière-plan : Spécificité à partir de Android 10
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget IOSApple WatchMac CatalystUniversal Windows 10 App
Autres
Procédures stockées
Affiche un message dans une boîte de dialogue standard proposant les réponses "OK" et "Annuler" et renvoie la réponse de l'utilisateur.
Dialogue OK / Annuler
Remarques :
  • Cette boîte de dialogue est bloquante. Pour continuer l'exécution de l'application, l'utilisateur doit valider un des boutons.
    AndroidiPhone/iPad Pour ne pas bloquer l'application, utilisez la fonction OKAnnulerAsynchrone.
Exemple
Universal Windows 10 AppAndroidiPhone/iPad
// Suppression d'une ligne avec confirmation (oui par défaut)
SI OKAnnuler("Supprimer cet enregistrement ?") ALORS
HSupprime(CLIENT)
FIN
Universal Windows 10 AppAndroidiPhone/iPad
// Choix pour la sortie du programme
SI OKAnnuler("Voulez-vous quitter le programme?") = Oui ALORS
Ferme()
FIN
Universal Windows 10 AppAndroidiPhone/iPad
// Demande de confirmation de la suppression du fichier dont
// le nom est contenu dans la variable NOM_FIC, avec
// positionnement sur le bouton "Non" de la fenêtre OKAnnuler
SI OKAnnuler(Non, "Supprimer le fichier ?") ALORS
fSupprime(NOM_FIC)
FIN
Syntaxe
Universal Windows 10 AppAndroidiPhone/iPad

Afficher une boîte de dialogue OK / Annuler Masquer les détails

<Résultat> = OKAnnuler([<Bouton sélectionné>, ] <Texte> [, <Ligne 2> [... [, <Ligne N>]]])
<Résultat> : Booléen
Identifie le bouton sélectionné par l'utilisateur :
FauxL'utilisateur a choisi le bouton "Annuler".
VraiL'utilisateur a choisi le bouton "OK".
<Bouton sélectionné> : Booléen optionnel
Bouton sélectionné par défaut dans la boîte de dialogue :
NonBouton "Annuler" sélectionné par défaut.
Vrai
(par défaut)
Bouton "OK" sélectionné par défaut.
<Texte> : Chaîne de caractères
Texte à afficher.
<Ligne 2> : Chaîne de caractères optionnelle
Texte affiché sur les lignes suivantes.
<Ligne N> : Chaîne de caractères optionnelle
Texte affiché sur les lignes suivantes.
Remarques

Caractéristiques de la boîte de dialogue

  • Le titre de la boîte de dialogue correspond au titre de la fenêtre (ou page) en cours.
    AndroidiPhone/iPad Pour respecter les spécifications du système, le titre de la boîte de dialogue est vide par défaut. Pour définir ce titre, utilisez la fonction TitreSuivant.
  • Pour modifier ou définir le titre de la boîte de dialogue, utilisez la fonction TitreSuivant.
  • Le message est cadré à gauche.
  • Les libellés des boutons dépendent de la langue d'exécution de Windows.
  • Le nombre maximum de caractères affichés est limité à 4096. Si une chaîne plus grande est passée en paramètre, elle sera tronquée.
  • L'icône affichée (point d'exclamation) ne peut pas être modifiée.

Saut de ligne dans la boîte de dialogue

La chaîne prédéfinie RC (Retour Chariot) peut être utilisée pour forcer le passage à la ligne suivante. Par exemple :
SI OKAnnuler("Attention : vous allez supprimer cet enregistrement" + RC + ...
"Voulez-vous continuer ?") ALORS
HSupprime(CLIENT)
FIN
est équivalent à :
SI OKAnnuler("Attention : vous allez supprimer cet enregistrement", ...
"Voulez-vous continuer ?") ALORS
HSupprime(CLIENT)
FIN
Il est également possible d'utiliser la syntaxe des chaînes multilignes. Par exemple :
OKAnnuler(
[
Attention : vous allez supprimer cet enregistrement.
 
Voulez-vous continuer ?
])
Universal Windows 10 AppAndroidiPhone/iPad

Divers

  • Les timers (fonction TimerSys) ne sont pas stoppés lors de l'appel de cette fonction.
  • Le libellé des boutons s'affiche dans la langue utilisée par Windows sur le poste en cours.
  • iPhone/iPad Cette fonction ne doit pas être utilisée :
    • dans l'événement "Modification de la taille" des fenêtres. Dans le cas contraire, l'application sera bloquée.
    • dans l'événement "Changement d'orientation" des fenêtres.
    • dans l'événement "Mise au premier-plan" associé au projet.
      Remarque : La fonction peut par contre être utilisée dans l'événement "Mise au premier plan" d'une fenêtre.
    • dans un thread.
Android

Application en arrière-plan : Spécificité à partir de Android 10

A partir de Android 10, il n'est plus possible d'ouvrir une fenêtre lorsque l'application est en arrière-plan.
La fonction OKAnnuler peut provoquer l'ouverture d'une fenêtre. Si cette fonction est utilisée alors que l'application est en arrière-plan, une erreur fatale sera générée.
Conseils :
  • Il est possible de savoir si l'application est en arrière-plan grâce à la fonction EnModeArrièrePlan.
  • Si une application a besoin d'interagir avec l'utilisateur alors qu'elle se trouve en arrière-plan, la solution consiste à afficher une notification (via le type Notification). Lors du clic sur la notification, l'application sera remise au premier plan si la propriété ActiveApplication est à Vrai. Il est également possible d'ouvrir une fenêtre depuis la procédure passée à la propriété ActionClic.
Classification Métier / UI : Code UI
Composante : wd280obj.dll
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire