PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Équivalence
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Renvoie le mode d'exécution de Windows.
Rappel : WINDEV permet de créer des exécutables 32 bits et 64 bits.
WEBDEV - Code Serveur Renvoie le mode d'exécution du serveur d'application WEBDEV.
Versions 15 et supérieures
PHP Cette fonction est désormais disponible pour les sites PHP.
Nouveauté 15
PHP Cette fonction est désormais disponible pour les sites PHP.
PHP Cette fonction est désormais disponible pour les sites PHP.
Exemple
// Connaître la version de Windows : 32 bits ou 64 bits

Version est un entier
Version = VersionWindows()
SELON Version
        CAS 32 : Info("Windows s'exécute en 32 bits")
        CAS 64 : Info("Windows s'exécute en 64 bits")
FIN
// Savoir si l'application en cours est 32 bits ou 64 bits

// La taille d'un entier système dépend du mode d'exécution (32/64 bits)
// En se basant sur cette taille, il est possible d'obtenir directement le mode d'exécution

// A partir de la version 16, il est possible d'utiliser la fonction EnMode64Bits.

EntierSystem est un entier système
EntierSystem = (Dimension(EntierSystem)*8)
SELON EntierSystem
CAS 32 : Info("Mode 32 bits")
CAS 64 : Info("Mode 64 bits")
AUTRE CAS : Info("Mode " + EntierSystem + " bits")
FIN
Syntaxe
<Résultat> = VersionWindows()
<Résultat> : Chaîne de caractères
Mode d'exécution du programme dans l'environnement en cours :
  • "32" : le programme fonctionne en 32 bits dans un environnement 32 bits.
  • "64" : le programme fonctionne en 32 bits ou en 64 bits dans un environnement 64 bits.
Remarques
Windows Mobile

Équivalence

Le fonctionnement de VersionWindows est équivalent au fonctionnement de ceVersionWindows.
Seule différence :
  • la fonction VersionWindows renvoie le mode d'exécution du programme lancé sur le Pocket PC à partir d'une application WINDEV Mobile.
  • la fonction ceVersionWindows renvoie le mode d'exécution du programme lancé sur le Pocket PC à partir d'une application WINDEV standard.
Composante : wd240std.dll
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire