PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

PV


WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget IOSApple WatchMac CatalystUniversal Windows 10 App
Autres
Procédures stockées
NbVignette (Propriété)
En anglais : NbThumbnail
HFSQLHFSQL Client/ServeurDisponible uniquement avec ces types de connexion
La propriété NbVignette permet de connaître le nombre de vignettes générées d'une rubrique. Cette rubrique a été définie sous l'éditeur d'analyses ou définie par programmation.
Remarque : Les vignettes HFSQL d'une rubrique sont générées automatiquement lors :
Exemple
// Connaître le nombre de vignettes générées
// et le nombre de vignettes attendues
// pour la rubrique Client.Photo
NombreVignette est un entier
NombreVignetteAttendu est un entier
NombreVignette = Client.Photo.NbVignette
NombreVignetteAttendu = Client.Photo.NbVignetteDécrit
// Nombre égal ?
SI NombreVignette = NombreVignetteAttendu ALORS
Info("Toutes les vignettes ont été générées")
SINON
POUR Nombre = 1 À NombreVignetteAttendu
ChaîneErreur += "Vignette " + Nombre + Client.Photo.InfoGénérationVignette[n] + RC
FIN
Erreur("Erreur de génération", ChaîneErreur)
FIN
Syntaxe
<Nombre de vignettes générées> = <Fichier de données>.<Rubrique>.NbVignette
<Nombre de vignettes générées> : Entier
Nombre de vignettes générées pour la rubrique spécifiée.
<Fichier de données> : Chaîne de caractères
Nom du fichier de données manipulé. Ce nom a été défini sous l'éditeur d'analyses ou grâce au type Description de Fichier.
<Rubrique> : Chaîne de caractères
Nom de la rubrique de type mémo binaire manipulée. Ce nom a été défini sous l'éditeur d'analyses ou grâce au type Description de Rubrique.
Remarques
La propriété NbVignette est disponible :
  • en HFSQL Classic et en HFSQL Mobile : sur les rubriques d'un fichier de données, d'une vue ou d'une requête.
  • en HFSQL Client/Serveur : sur les rubriques d'un fichier de données uniquement.
Linux La propriété NbVignette est disponible uniquement en HFSQL Client/Serveur sur les rubriques d'un fichier de données.
Version minimum requise
  • Version 10
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire