PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget iOSApple WatchCatalystUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
La propriété ..ToutModifiableAvecEtatsEtRequêtes permet de savoir si un état est modifiable sous le logiciel Etats & Requêtes. Lorsqu'un état est modifiable sous le logiciel Etats & Requêtes, il est possible de :
  • modifier son interface.
  • modifier son code.
  • supprimer un ou plusieurs de ses champs.
Remarques :
  • Cette fonctionnalité est définie sous l'éditeur lors de la description de l'état (sous l'onglet "Options" de la fenêtre de description, option "Etat modifiable sous Etats et Requêtes", sous-option "Tout modifiable (interface et code)").
  • La propriété ..InterfaceModifiableAvecEtatsEtRequêtes permet uniquement de savoir si l' interface d'un état est modifiable sous le logiciel Etats & Requêtes.
  • Pour plus de détails sur le logiciel Etats & Requêtes, consultez Logiciel Etats & Requêtes.
Exemple
// Etat modifiable sous Etats & Requêtes ?
SI ETAT_MonEtat..ToutModifiableAvecEtatsEtRequêtes = Vrai ALORS
// Mode WINDEV ?
SI EnModeWindows() = Vrai ALORS
// Ouverture de l'état sous Etats & Requêtes
LanceEtatsEtRequêtes(ETAT_MonEtat)
SINON
Info("Cet état est modifiable sous Etats & Requêtes")
FIN
SINON
Info("Cet état n'est pas modifiable sous Etats & Requêtes")
FIN
Syntaxe
<Résultat> = <Etat>..ToutModifiableAvecEtatsEtRequêtes
<Résultat> : Booléen
  • Vrai si l'état spécifié est modifiable sous le logiciel Etats & Requêtes,
  • Faux dans le cas contraire.
<Etat> : Nom d'état
Nom de l'état à manipuler.
Version minimum requise
  • Version 10
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire