PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget iOSApple WatchCatalystUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
La propriété ..InterfaceModifiableAvecEtatsEtRequêtes permet de savoir si l' interface d'un état est modifiable sous le logiciel Etats & Requêtes. Dans ce cas, il n'est pas possible de supprimer un ou plusieurs champs de cet état.
Remarques :
  • Cette fonctionnalité est définie sous l'éditeur lors de la description de l'état (onglet "Détail" de la fenêtre de description, options "Etat modifiable sous Etats et Requêtes" et "Interface modifiable uniquement").Cette fonctionnalité est définie sous l'éditeur lors de la description de l'état (onglet "Options" de la fenêtre de description, options "Etat modifiable sous Etats et Requêtes" et "Interface modifiable uniquement").
  • La propriété ..ToutModifiableAvecEtatsEtRequêtes permet de savoir si un état est entièrement modifiable sous le logiciel Etats & Requêtes.
  • Pour plus de détails sur le logiciel Etats & Requêtes, consultez Logiciel Etats & Requêtes.
Exemple
// Interface de l'état modifiable sous Etats & Requêtes ?
SI MonEtat..InterfaceModifiableAvecEtatsEtRequêtes = Vrai ALORS
// Mode WinDev ?
SI EnModeWindows() = Vrai ALORS
// Ouverture de l'état sous Etats & Requêtes
LanceEtatsEtRequêtes(MonEtat)
SINON
Info("L'interface de cet état est modifiable sous Etats & Requêtes")
FIN
SINON
Info("L'interface de cet état n'est pas modifiable sous Etats & Requêtes")
FIN
Syntaxe
<Résultat> = <Etat>..InterfaceModifiableAvecEtatsEtRequêtes
<Résultat> : Booléen
  • Vrai si l'interface de l'état spécifié est modifiable sous le logiciel Etats & Requêtes,
  • Faux dans le cas contraire.
<Etat> : Nom d'état
Nom de l'état à manipuler.
Version minimum requise
  • Version 10
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire