PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Présentation
  • Installer le Framework .NET ou le SDK
  • Vérifier si le Framework .NET est installé sur le poste en cours
  • Installer le Framework .NET sur le poste en cours (.Net version 2.0, 3.x, ou 4.x)
  • Installer le SDK .NET 5.0
  • Installer la LibC
  • Régler le niveau de sécurité .NET
  • Rendre accessibles les DLLs nécessaires à l'exécution de l'assemblage .NET
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget IOSApple WatchMac CatalystUniversal Windows 10 App
Autres
Procédures stockées
Présentation
Pour créer et utiliser un assemblage .NET sous WINDEV, il est nécessaire de :
Remarques :
  • Par défaut, lors de l'utilisation d'un assemblage .NET, c'est le framework/runtime le plus récent qui est utilisé.
  • Sur le poste où l'assemblage .NET sera utilisé, il est nécessaire d'installer le runtime correspondant et la LibC.
Installer le Framework .NET ou le SDK

Vérifier si le Framework .NET est installé sur le poste en cours

Pour vérifier si le Framework .NET est installé sur le poste en cours :
  1. Ouvrez le panneau de configuration de Windows (option "Démarrer .. Paramètres .. Panneau de configuration") et sélectionnez l'option "Ajout / Suppression de programmes".
  2. Recherchez dans la liste le programme "Framework .NET".

Installer le Framework .NET sur le poste en cours (.Net version 2.0, 3.x, ou 4.x)

Pour installer le Framework .NET sur le poste de développement :
  1. Consultez le site de Microsoft à l'adresse suivante : https://dotnet.microsoft.com/download/visual-studio-sdks.
  2. Dans la partie ".NET Framework", recherchez l'installation du Framework .NET voulu (version 2.0, 3.x, ou 4.x).
  3. Installez le Framework .NET voulu.
  4. Installez le "Runtime" correspondant.
Versions 27 et supérieures

Installer le SDK .NET 5.0

Pour installer le SDK .NET 5.0 sur le poste de développement :
  1. Consultez le site de Microsoft à l'adresse suivante : https://dotnet.microsoft.com/download/visual-studio-sdks
  2. Dans la partie ".NET/.NET Core" :
    • Téléchargez et installez le SDK .NET voulu (64 bits).
    • Téléchargez et installez le "Runtime" correspondant (64 bits).
Nouveauté 27

Installer le SDK .NET 5.0

Pour installer le SDK .NET 5.0 sur le poste de développement :
  1. Consultez le site de Microsoft à l'adresse suivante : https://dotnet.microsoft.com/download/visual-studio-sdks
  2. Dans la partie ".NET/.NET Core" :
    • Téléchargez et installez le SDK .NET voulu (64 bits).
    • Téléchargez et installez le "Runtime" correspondant (64 bits).

Installer le SDK .NET 5.0

Pour installer le SDK .NET 5.0 sur le poste de développement :
  1. Consultez le site de Microsoft à l'adresse suivante : https://dotnet.microsoft.com/download/visual-studio-sdks
  2. Dans la partie ".NET/.NET Core" :
    • Téléchargez et installez le SDK .NET voulu (64 bits).
    • Téléchargez et installez le "Runtime" correspondant (64 bits).
Installer la LibC
La DLL .NET a besoin de la LibC. Elle ne se charge pas sur des machines sur lesquelles aucune autre application n'a encore installé la LibC.
La version distribuable de la LibC est librement téléchargeable sur le site de Microsoft : https://docs.microsoft.com/en-us/cpp/windows/latest-supported-vc-redist?view=msvc-170
Régler le niveau de sécurité .NET
Pour régler le niveau de sécurité .NET, nous vous conseillons de consulter la documentation Microsoft. Le niveau de sécurité doit être réglé sur "Confiance totale".
Rendre accessibles les DLLs nécessaires à l'exécution de l'assemblage .NET
Pour rendre accessibles les DLLs nécessaires à l'exécution de l'assemblage .NET :
  1. Copiez si nécessaire la librairie "WDxxNET.DLL" (cette librairie est disponible dans le sous-répertoire "\Programmes" du répertoire d'installation) :
    • soit dans le répertoire de l'assemblage .NET.
    • soit dans le sous-répertoire "Assembly" du répertoire d'installation de Windows.
      • Pour un assemblage .NET 2.0, la DLL à copier est wdxxxnet2.dll.
      • Pour un assemblage .NET 2.0 en 64 bits, la DLL à copier est wdxxxnet2_64.dll.
      • Pour un assemblage .NET 4.0, la DLL à copier est wdxxxnet4.dll.
      • Pour un assemblage .NET 4.0 en 64 bits, la DLL à copier est wdxxxnet4_64.dll.
      • Versions 27 et supérieures
        Pour un assemblage .NET 5.0, la DLL à copier est wdxxxnet5.dll.
        Nouveauté 27
        Pour un assemblage .NET 5.0, la DLL à copier est wdxxxnet5.dll.
        Pour un assemblage .NET 5.0, la DLL à copier est wdxxxnet5.dll.
      • Versions 27 et supérieures
        Pour un assemblage .NET 5.0 en 64 bits, la DLL à copier est wdxxxnet5_64.dll.
        Nouveauté 27
        Pour un assemblage .NET 5.0 en 64 bits, la DLL à copier est wdxxxnet5_64.dll.
        Pour un assemblage .NET 5.0 en 64 bits, la DLL à copier est wdxxxnet5_64.dll.
  2. Copiez si nécessaire les librairies WINDEV :
    • soit dans le répertoire de l'assemblage .NET.
    • soit dans le PATH.
Rappel : Le PATH liste les répertoires dans lesquels les exécutables (fichiers ".EXE") et les librairies (fichiers ".DLL") sont recherchés en priorité.
Version minimum requise
  • Version 9
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire