PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

Nouveauté WINDEV, WEBDEV, WINDEV Mobile 24 !
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
UTILISER DANS (Chronomètre)
En anglais : USING IN
L'instruction UTILISER ... DANS permet d'effectuer automatiquement les opérations de déclenchement et d'arrêt d'un chrono.
Cette instruction permet principalement de simplifier le cumul de chronomètres sur plusieurs itérations.
Si le chronomètre est arrêté au début du bloc, il est automatiquement déclenché en sortie du bloc.
Exemple
c est un Chrono
 
UTILISER c DANS
ThreadPause(2s)
SI Vrai ALORS
SORTIR
// Le calcul du chronomètre s'arrête
FIN
FIN
 
ThreadPause(2s) // Ce code n'est pas pris en compte dans le calcul du chronomètre
 
UTILISER c DANS
ThreadPause(2s)
FIN
 
Info(c)
Syntaxe
UTILISER <Chronomètre> DANS

    ...
FIN
<UTILISER DANS> :
Signale le début du bloc d'instructions.
<Chronomètre> : Variable de type Chrono
Nom de la variable de type Chrono correspondant au chronométrage à réaliser.
Version minimum requise
  • Version 24
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire