PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Autres instructions permettant de sortir d'une boucle
  • Exemple d'utilisation de l'étiquette "SORTIR:"
  • Instruction "SORTIR:" : Cas des boucles imbriquées
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget iOSApple WatchCatalystUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Le mot-clé SORTIR peut correspondre :
  • à l'instruction SORTIR :
    L'instruction SORTIR permet de sortir d'un bloc d'instructions et d'exécuter la suite du traitement en cours.
    L'instruction SORTIR peut être utilisée dans les boucles de type : Remarque : L'instruction SORTIR ne peut pas être utilisée pour sortir d'une procédure. Utilisez les mots-clés RETOUR ou RENVOYER.
  • Versions 19 et supérieures
    à l'étiquette SORTIR: :
    L'étiquette "SORTIR:" permet de déclarer un code dans une boucle.
    • Ce code sera exécuté uniquement lors de la sortie de la boucle par l'instruction "SORTIR".
    • Ce code ne sera jamais exécuté à chaque itération de la boucle.
    Nouveauté 19
    à l'étiquette SORTIR: :
    L'étiquette "SORTIR:" permet de déclarer un code dans une boucle.
    • Ce code sera exécuté uniquement lors de la sortie de la boucle par l'instruction "SORTIR".
    • Ce code ne sera jamais exécuté à chaque itération de la boucle.
    à l'étiquette SORTIR: :
    L'étiquette "SORTIR:" permet de déclarer un code dans une boucle.
    • Ce code sera exécuté uniquement lors de la sortie de la boucle par l'instruction "SORTIR".
    • Ce code ne sera jamais exécuté à chaque itération de la boucle.
Syntaxe

Instruction SORTIR utilisée dans une instruction POUR

POUR <Variable de contrôle> = <Valeur initiale> A <Valeur finale> [PAS <x>]
  ...
  SI <Condition> ALORS SORTIR
  ...
FIN
<Suite du traitement>

Instruction SORTIR utilisée dans une instruction POUR TOUT

POUR TOUT <Fichier> SUR <Rubrique clé>
  ...
  SI <Condition> ALORS SORTIR
  ...
FIN
<Suite du traitement>

Instruction SORTIR utilisée dans une instruction BOUCLE

BOUCLE
  ...
  SI <Condition> ALORS SORTIR
  ...
FIN
<Suite du traitement>

Instruction SORTIR utilisée dans une instruction TANTQUE

TANTQUE <Condition>
  ...
  SI <Condition> ALORS SORTIR
  ...
FIN
<Suite du traitement>
Dans tous les cas, si la <Condition> est vérifiée, les opérations effectuées sont les suivantes :
- Sortie du bloc d'instructions.
- Exécution de la suite du traitement en cours.
Remarques

Autres instructions permettant de sortir d'une boucle

Plusieurs instructions sont possibles :
  • RETOUR : Sortie de la boucle et sortie du traitement (ou de la procédure) en cours.
  • RENVOYER : Renvoi d'un compte-rendu au traitement appelant. Sortie de la boucle et sortie du traitement (ou de la procédure) en cours.
La fonction Ferme permet de sortir de la boucle et de fermer la fenêtre en cours.
Attention : Il n'est pas possible d'utiliser les instructions RETOUR et RENVOYER dans un même traitement.
Versions 19 et supérieures

Exemple d'utilisation de l'étiquette "SORTIR:"

Dans cet exemple, le total représentant la somme des 10 dernières factures est affiché.
NbFactures est un entier
TotFact est un monétaire

NbFactures = 0
HLitDernier(Facture, NumFact)
TANTQUE PAS HEnDehors()
NbFactures ++
SI NbFactures >= 10  ALORS SORTIR // Saute directement au label SORTIR:
  // Cumule les factures
TotFact += Facture.Montant

SORTIR:
// Sort de la boucle au bout de 10 itérations
Info("Le total des 10 dernières factures est : ", TotFact)
HLitPrécédent(Facture, NumFact)
FIN
Nouveauté 19

Exemple d'utilisation de l'étiquette "SORTIR:"

Dans cet exemple, le total représentant la somme des 10 dernières factures est affiché.
NbFactures est un entier
TotFact est un monétaire

NbFactures = 0
HLitDernier(Facture, NumFact)
TANTQUE PAS HEnDehors()
NbFactures ++
SI NbFactures >= 10  ALORS SORTIR // Saute directement au label SORTIR:
  // Cumule les factures
TotFact += Facture.Montant

SORTIR:
// Sort de la boucle au bout de 10 itérations
Info("Le total des 10 dernières factures est : ", TotFact)
HLitPrécédent(Facture, NumFact)
FIN

Exemple d'utilisation de l'étiquette "SORTIR:"

Dans cet exemple, le total représentant la somme des 10 dernières factures est affiché.
NbFactures est un entier
TotFact est un monétaire

NbFactures = 0
HLitDernier(Facture, NumFact)
TANTQUE PAS HEnDehors()
NbFactures ++
SI NbFactures >= 10  ALORS SORTIR // Saute directement au label SORTIR:
  // Cumule les factures
TotFact += Facture.Montant

SORTIR:
// Sort de la boucle au bout de 10 itérations
Info("Le total des 10 dernières factures est : ", TotFact)
HLitPrécédent(Facture, NumFact)
FIN
Versions 19 et supérieures

Instruction "SORTIR:" : Cas des boucles imbriquées

Il est parfois nécessaire lors de plusieurs boucles imbriquées de sortir d'une imbrication pour remonter au niveau précédent ou même à un niveau encore plus haut.
Pour cela, l'instruction SORTIR accepte un paramètre indiquant le nombre de niveau à remonter pour la sortie. La syntaxe est la suivante :
SORTIR(<Nombre de niveau>)
où <Nombre de niveau> est un entier entre 1 et N, N représentant le nombre de niveau d'imbrications de boucles.
Par exemple :
x, y, z sont des entiers

POUR x = 1 A 15 // Boucle 1
POUR y = 1 A 25 // Boucle 2
POUR z = 1 A 50 // Boucle 3
SI <Ma condition est vérifiée> ALORS
SORTIR(2)  // Sort de la boucle 3 et de la boucle 2
// et passe à l'itération suivante de la boucle 1
FIN
FIN
FIN
FIN
Nouveauté 19

Instruction "SORTIR:" : Cas des boucles imbriquées

Il est parfois nécessaire lors de plusieurs boucles imbriquées de sortir d'une imbrication pour remonter au niveau précédent ou même à un niveau encore plus haut.
Pour cela, l'instruction SORTIR accepte un paramètre indiquant le nombre de niveau à remonter pour la sortie. La syntaxe est la suivante :
SORTIR(<Nombre de niveau>)
où <Nombre de niveau> est un entier entre 1 et N, N représentant le nombre de niveau d'imbrications de boucles.
Par exemple :
x, y, z sont des entiers

POUR x = 1 A 15 // Boucle 1
POUR y = 1 A 25 // Boucle 2
POUR z = 1 A 50 // Boucle 3
SI <Ma condition est vérifiée> ALORS
SORTIR(2)  // Sort de la boucle 3 et de la boucle 2
// et passe à l'itération suivante de la boucle 1
FIN
FIN
FIN
FIN

Instruction "SORTIR:" : Cas des boucles imbriquées

Il est parfois nécessaire lors de plusieurs boucles imbriquées de sortir d'une imbrication pour remonter au niveau précédent ou même à un niveau encore plus haut.
Pour cela, l'instruction SORTIR accepte un paramètre indiquant le nombre de niveau à remonter pour la sortie. La syntaxe est la suivante :
SORTIR(<Nombre de niveau>)
où <Nombre de niveau> est un entier entre 1 et N, N représentant le nombre de niveau d'imbrications de boucles.
Par exemple :
x, y, z sont des entiers

POUR x = 1 A 15 // Boucle 1
POUR y = 1 A 25 // Boucle 2
POUR z = 1 A 50 // Boucle 3
SI <Ma condition est vérifiée> ALORS
SORTIR(2)  // Sort de la boucle 3 et de la boucle 2
// et passe à l'itération suivante de la boucle 1
FIN
FIN
FIN
FIN
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Faute dans l'exemple
Dans : Exemple d'utilisation de l'étiquette "SORTIR:"

Je pense qu'on doit plutôt écrire :
HlitPremier (Facture, NumFact) et non pas HlitDernier.
Badreddine
12 mar. 2019