PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

PV

  • Autres instructions permettant de sortir d'une boucle ou d'une procédure
  • Utilisation du mot-clé RETOUR pour renvoyer une valeur
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget IOSApple WatchMac CatalystUniversal Windows 10 App
Autres
Procédures stockées
Instruction RETOUR
En anglais : RETURN
AjaxNon disponible
L'instruction RETOUR permet de sortir d'un bloc d'instructions et de sortir du traitement (ou de la procédure) en cours.
L'instruction RETOUR peut être utilisée dans :
Dans une procédure, il est également possible d'affecter une valeur au mot-clé RETOUR. Cette valeur peut être relue à tout moment. Cette valeur sera automatiquement renvoyée à la sortie de la procédure (sortie normale de la procédure ou sortie de la procédure par le mot-clé RETOUR).
Syntaxe

Procédure

PROCEDURE <Nom de la procédure> ([<Paramètre>])
  SI <Condition> ALORS RETOUR
  ...
  FIN

Instruction POUR

POUR <Variable de contrôle> = <Valeur initiale> A <Valeur finale> [PAS <x>]
  SI <Condition> ALORS RETOUR
FIN

Instruction POUR TOUT

POUR TOUT <Fichier> SUR <Rubrique clé>
  SI <Condition> ALORS RETOUR
FIN

Instruction BOUCLE

BOUCLE
  ...
  SI <Condition> ALORS RETOUR
  ...
FIN

Instruction TANTQUE

TANTQUE <Condition 1>
  ...
  SI <Condition> ALORS RETOUR
  ...
FIN
Dans tous les cas, si la <Condition> est vérifiée, les opérations effectuées sont les suivantes :
  • Sortie du bloc d'instructions.
  • Sortie du traitement (ou de la procédure) en cours.
Remarques

Autres instructions permettant de sortir d'une boucle ou d'une procédure

Plusieurs instructions sont possibles :
  • RENVOYER : Renvoi d'un compte-rendu au traitement appelant. Sortie de la boucle et sortie du traitement (ou de la procédure) en cours.
  • SORTIR : Sortie de la boucle et exécution de la suite du traitement (ou de la procédure) en cours.
La fonction Ferme permet de sortir de la boucle (ou de la procédure) et de fermer la fenêtre en cours.

Utilisation du mot-clé RETOUR pour renvoyer une valeur

Dans une procédure, il est possible d'affecter la valeur de retour avant la sortie effective de la procédure. Par exemple :
...
RETOUR = fLitLigne(nFichier)
fFerme(nFichier)
Il est également possible de relire la valeur affectée à RETOUR, ce qui évite de déclarer une variable locale pour contenir le résultat. Par exemple :
SI RETOUR = 1 ALORS ...
La valeur affectée à RETOUR sera renvoyée au traitement appelant :
  • à la fin de la procédure
  • lors de l'utilisation du mot-clé RETOUR pour sortir du traitement (équivalent à l'instruction RENVOYER).
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire