PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE


Nouveauté WINDEV 27 !
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget IOSApple WatchMac CatalystUniversal Windows 10 App
Autres
Procédures stockées
Procédure WLangage appelée par la fonction OuvreDocumentAsynchrone
Procédure WLangage (appelée "callback") appelée par la fonction OuvreDocumentAsynchrone après la fermeture de la fenêtre d'édition. Cette procédure peut être une procédure locale, globale ou interne.
Exemple
PROCÉDURE INTERNE OuvreDocumentAsynchrone_Callback(sDoc, nCompteRendu)
SI nCompteRendu = odOuvertModifié ALORS
Info(sDoc + " a été modifié.")
FIN
FIN
 
SI PAS OuvreDocumentAsynchrone(sDocument, "Mon document", ...
odOptionAucune, "", OuvreDocumentAsynchrone_Callback) ALORS
Erreur("Impossible d'ouvrir le document.")
FIN
Syntaxe
OuvreDocumentAsynchrone_Callback(<Document> , <Compte-rendu>)
<Document> : Chaîne de caractères
Document ouvert par la fonction OuvreDocumentAsynchrone.
<Compte-rendu> : Entier
Compte-rendu de l'ouverture du document :
odEchecLe document n'a pas pu être ouvert.
odOuvertModifiéLe document a été ouvert et a été modifié.
odOuvertNonModifiéLe document a été ouvert mais il n'a pas été modifié.
Composante : wd270obj.dll
Version minimum requise
  • Version 27
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire