DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget IOSApple WatchMac CatalystUniversal Windows 10 App
Autres
Procédures stockées
Procédure WLangage appelée par la fonction OuvrePopupAsynchrone
Procédure WLangage (appelée "callback") appelée par la fonction OuvrePopupAsynchrone après la fermeture de la fenêtre popup. Cette procédure peut être une procédure locale, globale ou interne.
Exemple
// Ouverture d'une fenêtre popup sans passage de paramètres
OuvrePopupAsynchrone(FEN_ChoixCouleur, popEnDessous + popAlignéAGauche + popSelonChamp,
"BTN_CouleurAction", onFermeChoixCouleur)
PROCÉDURE INTERNE onFermeChoixCouleur(CouleurChoisie)
IMG_PRODUIT.Couleur = CouleurChoisie
FIN
// Ouverture d'une fenêtre popup avec passage de paramètres
OuvrePopupAsynchrone(FEN_ChoixCouleur, popEnDessous + popAlignéAGauche + popSelonChamp,
"BTN_CouleurAction", onFermeChoixCouleur, RougeFoncé)
PROCÉDURE INTERNE onFermeChoixCouleur(CouleurChoisie)
SI CouleurChoisie <> -1 ALORS
IMG_PRODUIT.Couleur = CouleurChoisie
FIN
FIN
Syntaxe
OuvrePopupAsynchrone_Callback(<Valeur de retour>)
<Valeur de retour> : Type de la valeur de retour
Correspond à la valeur qui sera renvoyée par la fenêtre popup. Cette valeur peut être renvoyée par exemple :
  • via l'instruction RENVOYER dans le code de fermeture de la fenêtre popup,
  • via la fonction Ferme (syntaxe Ferme("", Valeur)),
  • via la propriété ValeurRenvoyée de la fenêtre popup.
Composante : wd280obj.dll
Version minimum requise
  • Version 27
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire