PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Présentation
  • Exemples
  • Exemple 1
  • Exemple 2
  • Exemple 3
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget iOSApple WatchCatalystUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Présentation
Versions 16 et supérieures
WINDEVWindows Mobile Le data binding est proposé sur les champs Arbre : le champ peut être directement lié à un fichier de données ou à une variable. Pour plus de détails, consultez Champ Arbre lié à une variable ou un fichier de données.
Nouveauté 16
WINDEVWindows Mobile Le data binding est proposé sur les champs Arbre : le champ peut être directement lié à un fichier de données ou à une variable. Pour plus de détails, consultez Champ Arbre lié à une variable ou un fichier de données.
WINDEVWindows Mobile Le data binding est proposé sur les champs Arbre : le champ peut être directement lié à un fichier de données ou à une variable. Pour plus de détails, consultez Champ Arbre lié à une variable ou un fichier de données.
Par défaut, le champ Arbre ne peut pas afficher automatiquement les données provenant d'un fichier de données.
Voici quelques exemples permettant de réaliser cette opération.
Voici un algorithme permettant de remplir un champ Arbre à partir d'un fichier de données :
// Parcours du fichier de données
HLitPremier(NomFichier, NomClé)
TANTQUE HEnDehors() = Faux
// Ajout dans le champ Arbre
ArbreAjoute(ARBRE_NomChampArbre, MaRacine + TAB + Branche + TAB + Feuille)
HLitSuivant(NomFichier, NomClé)
FIN
Exemples

Exemple 1

// Parcours du fichier de données
HLitPremier(Societe, Ville)
TANTQUE HEnDehors() = Faux
// Ajout dans le champ Arbre
ArbreAjoute(ARBRE_NomChampArbre, Societe.Ville + TAB + Societe.NomSoc)
HLitSuivant(Societe, Ville)
FIN

Exemple 2

// Parcours du fichier de données
HLitPremier(Client, NomCli)
TANTQUE HEnDehors() = Faux
// Ajout dans le champ Arbre
ArbreAjoute(ARBRE_NomChampArbre, Gauche(Client.NomCli, 1) + TAB + Client.NomCli)
HLitSuivant(Client, NomCli)
FIN

Exemple 3

// Parcours du fichier de données
POUR TOUT Client SUR NomCli
// Ajout dans le champ Arbre
ArbreAjoute(ARBRE_NomChampArbre, Gauche(Client.NomCli, 1) + TAB + Client.NomCli)
FIN
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire