PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Exemple : Parcours d'agendas Google
GglRécupèreAgenda (Exemple)
Exemple : Parcours d'agendas Google
Cet exemple permet de parcourir les différents agendas d'un compte Google. Pour chaque agenda, les événements associés sont parcourus, et pour chaque événement, les lieux associés sont parcourus.
// Connexion à Google
Cnx est un gglConnexion
...
 
// Récupération du tableau des agendas disponibles
tabAgendas est un tableau de gglAgenda
tabAgendas = GglListeAgenda(Cnx)
 
// Parcours
tabAgendasParcoursEvénement est un gglAgenda
UnAgenda est un gglAgenda
UnEvénement est un gglEvénement
UnLieu est un gglLieu
 
// Parcours de tous les agendas disponibles, on récupère les événements
POUR TOUT ELÉMENT UnAgenda DE tabAgendas
Trace("Agenda " + UnAgenda.Titre + ...
 " (mis à jour le " + DateVersChaîne(UnAgenda.DateMiseAJour[[À 8]]) + ...
 " à " + HeureVersChaîne(UnAgenda.DateMiseAJour[[9 À]]) + ")")
tabAgendasParcoursEvénement = GglRécupèreAgenda(Cnx, UnAgenda.Identifiant)
 
// Parcours de tous les événements de l'agenda en cours
POUR TOUT UnEvénement DE tabAgendasParcoursEvénement
Trace("------------------------------")
Trace(UnEvénement..Titre)
Trace("Du " + DateVersChaîne(UnEvénement.DateDébut[[À 8]]) + ...
  " à " + HeureVersChaîne(UnEvénement.DateDébut[[9 À]])+")" + ...
  " au " + DateVersChaîne(UnEvénement.DateFin[[À 8]])+ " à " + ...
  HeureVersChaîne(UnEvénement.DateFin[[9 À]]) + ")")  
 
// Parcours des lieux de l'événement
POUR TOUT ELÉMENT UnLieu DE UnEvénement.Lieu
  Trace("Lieu de l'événement : " + UnLieu.Valeur + "//" + UnLieu.Libellé)
FIN
FIN
FIN
Version minimum requise
  • Version 14
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire