PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Exemple : attendre l'état d'un service
ServiceAttendEtat (Exemple)
Exemple : attendre l'état d'un service
// Attend que le service présent dans la table TABLE_Service soit démarré
Res est un entier
Res = ServiceAttendEtat(COL_Nom[TABLE_Service], "", serviceEtatDémarré, 10)
SI Res = -1 ALORS
Erreur(ErreurInfo())
SINON
Info("Etat en fin de timeout : " + EtatEnTexte(Res)
FIN

FONCTION EtatEnTexte(plEtat)
lsRésultat est une chaîne
SELON plEtat
CAS serviceEtatArrêté: lsRésultat = "serviceEtatArrêté"
CAS serviceEtatAttenteArrêt: lsRésultat = "serviceEtatAttenteArrêt"
CAS serviceEtatAttenteDémarrage: lsRésultat = "serviceEtatAttenteDémarrage"
CAS serviceEtatAttentePause: lsRésultat = "serviceEtatAttentePause"
CAS serviceEtatAttenteRelancement: lsRésultat = "serviceEtatAttenteRelancement"
CAS serviceEtatDémarré: lsRésultat = "serviceEtatDémarré"
CAS serviceEtatEnPause: lsRésultat = "serviceEtatEnPause"
CAS serviceEtatTimeout: lsRésultat = "serviceEtatTimeout"
AUTRE CAS:
FIN
RENVOYER lsRésultat
Version minimum requise
  • Version 11
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire