PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Exemple : appel de procédure
DotNetDélégué (Exemple)
Exemple : appel de procédure
WINDEVWEBDEV - Code ServeurEtats et RequêtesWindowsCode Utilisateur (MCU)
//------------------------------------------------
clDotNet est un ClasseGestionEvenement

clDotNet:add_m_LogHandler(DotNetDélégué("Proc_Handler", ...
"EventHandler<DllDotNetDelegué.MsgEvent>"))
clDotNet:add_m_LogHandler(DotNetDélégué("Proc_Test", ...
"EventHandler<DllDotNetDelegué.MsgEvent>"))

clDotNet:EnvoiUnMessage(gsChaineEnvoyée)
//-------------------------------------------------

PROCEDURE Proc_Test(src, args)

//Variable globale pour indiquer que le délégué a bien été appelé
gbDélégueAppelé = Vrai

sChaine est une chaîne = args:get_Message()
pclMesObj est un MsgEvent dynamique = args

SI sChaine = gsChaineEnvoyée ALORS
Info("1) Ok : la chaîne passée en paramètre via le délégué " + ...
"est identique à la chaîne reçue")
SINON
Info("1) La chaîne passée en paramètre via le délégué " + ...
"n'est pas identique à la chaîne reçue. " + ...
sChaine + " au lieu de " + gsChaineEnvoyée)
FIN

SI pclMesObj:get_Message() = gsChaineEnvoyée ALORS
Info("2) Ok : la chaîne passée en paramètre via le délégué " + ...
"est identique à la chaîne reçue")
SINON
Info("2) La chaîne passée en paramètre via le délégué " + ...
"n'est pas identique à la chaîne reçue. " + ...
pclMesObj:get_Message() + " au lieu de " + gsChaineEnvoyée)
FIN
Version minimum requise
  • Version 11
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire