PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Liste des colonnes d'une vue
NotesVueListeColonne (Exemple)
Liste des colonnes d'une vue
L'exemple suivant permet de lister les colonnes présentes dans une vue :
// Ouverture de la connexion
IDConnexion est un entier
IDConnexion = NotesOuvreConnexion("MotDePasse", "ServeurMars", "C:\Lotus Notes\julie.id")

// Spécification de la base Lotus Notes à utiliser
IDBase est un entier
IDBase = NotesOuvreBase(IDConnexion, "julie.nsf")
...

// Activation de la vue
NotesActiveVue(IDBase, "MesClients")
// Liste des colonnes triables de cette vue
ListeColonne est une chaîne
ListeColonne = NotesVueListeColonne(IDBase)

UneColonne est une chaîne
NomColonne est une chaîne
TypeColonne est un entier
ColonneTriable est un booléen
TriCroissant est un booléen
SensibleCasse est un booléen
SensibleAccent est un booléen

// Pour chaque colonne
POUR TOUTE CHAÎNE UneColonne DE ListeColonne SEPAREE PAR RC
// Extraction des différentes informations
// Exemple, la colonne MaColonne est de type Texte.
// Cette colonne est triable, triée dans l'ordre croissant,
// sensible à la casse.
// ListeColonne est de la forme :
// "MaColonne+TAB+notesTypeTexte+TAB+1+TAB+1+TAB+1+TAB+0"
NomColonne = ExtraitChaîne(UneColonne, 1)
TypeColonne = ExtraitChaîne(UneColonne, 2)
ColonneTriable = ExtraitChaîne(UneColonne, 3)
TriCroissant = ExtraitChaîne(UneColonne, 4)
SensibleCasse = ExtraitChaîne(UneColonne, 5)
SensibleAccent = ExtraitChaîne(UneColonne, 6)

// Affichage de ces informations
Trace("La colonne " + NomColonne + " est :")

SELON TypeColonne
CAS notesTypeTexte: Trace(" - de type texte")
CAS notesTypeNombre: Trace(" - de type nombre")
CAS notesTypeTexteRiche: Trace(" - de type texte riche")
CAS notesTypeDateHeure: Trace(" - de type dateheure")
FIN

Trace(ColonneTriable ? " - triable" SINON " - non triable")

SI ColonneTriable ALORS
Trace(" - triée dans l'ordre ", ...
TriCroissant ? "croissant" SINON "décroissant")
Trace(SensibleCasse ? " - sensible à la casse" SINON ...
" - non-sensible à la casse")
Trace(SensibleAccent ? " - sensible aux accents" SINON ...
" - non-sensible aux accents")
FIN

Trace("------------")
FIN
Version minimum requise
  • Version 11
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire