PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

Nouveauté WINDEV, WEBDEV et WINDEV Mobile 26 !
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget iOSApple WatchCatalystUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
<AuthToken>.RenouvelleToken (Fonction)
En anglais : <AuthToken>.RefreshToken
Renouvelle un token OAuth2 d’un utilisateur si ce token est expiré.
Exemple
gToken est un AuthToken
 
// Obtention d'un token
OAuth2Params est OAuth2Paramètres
OAuth2Params.ClientID = "1060349503186-pc7ahmeb6h6mc3jd19nlva26kt7gk59q.apps.googleusercontent.com"
OAuth2Params.ClientSecret = "oBTQL52JiT82Wmuy9-76MpiM"
OAuth2Params.URLAuth = "https://accounts.google.com/o/oauth2/v2/auth"
OAuth2Params.URLToken = "https://www.googleapis.com/oauth2/v4/token"
OAuth2Params.Scope = "email profile openid"
OAuth2Params.URLRedirection = "http://localhost:9846"
 
// Demande d'authentification : ouvre la fenêtre de login
gToken = AuthIdentifie(OAuth2Params)
 
SI PAS gToken.Valide ALORS
SI ErreurDétectée ALORS
Info(ErreurInfo(errComplet))
SINON
Info("L'authentification a échoué")
FIN
RETOUR
FIN
 
MonIdentité est un OpenIDIdentité = gToken.OpenIDLitIdentité()
 
Trace("Token = " + gToken.Valeur + RC + "Date d'expiration = " + ...
gToken.DateExpiration.VersChaîne() + RC + "RefreshToken = " + ...
gToken.Actualisation + RC + RC + MonIdentité.Email)
 
// Renouvellement du token
 
gToken = gToken.AuthRenouvelleToken()
 
SI PAS gToken.Valide ALORS
SI ErreurDétectée ALORS
Info(ErreurInfo(errComplet))
SINON
Info("Echec")
FIN
RETOUR
FIN
 
Trace("Token = " + gToken.Valeur + RC + "Date d'expiration = " + ...
gToken.DateExpiration.VersChaîne() + RC + ...
"RefreshToken = " + gToken.Actualisation)
Syntaxe
<Résultat> = <Token>.RenouvelleToken()
<Résultat> : Variable de type AuthToken
Variable de type AuthToken correspondant au token renouvelé.
<Token> : Nom de champ
Nom de la variable de type AuthToken correspondant au token à renouveler. Ce token est obtenu par exemple avec la fonction AuthIdentifie.
Remarques
Selon le token, il n'est pas toujours possible de le renouveler. La propriété Actualisation de la variable de type AuthToken permet de savoir si le token est renouvelable.
Composante : wd260ggl.dll
Version minimum requise
  • Version 26
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire