PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

Nouveauté WINDEV, WEBDEV et WINDEV Mobile 26 !
  • Propriétés spécifiques à la description des variables de type gglSurcharge
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget iOSApple WatchCatalystUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Le type gglSurcharge permet de définir les informations sur la surcharge d'une notification d'un événement. Les caractéristiques de cette surcharge peuvent être définies et modifiées à l'aide de différentes propriétés WLangage.
Ce type de variable est manipulé via les variables de type gglNotification.
Remarque : Pour plus de détails sur la déclaration de ce type de variable et l'utilisation des propriétés WLangage, consultez Déclaration d'une variable.
Exemple
// Connexion à Google
Cnx est un gglConnexion
Cnx.Email = "balthazar@gmail.com"
Cnx.MotDePasse = "azerty"
Cnx.NomApplication = "MonAppli-01"
SI GglConnecte(Cnx) = Faux ALORS
Erreur(ErreurInfo())
FIN
...
// Récupération du tableau des agendas disponibles
tabAgendas est un tableau de gglAgenda
tabAgendas = GglListeAgenda(Cnx)
// Récupération de tous les événements du premier agenda
GglRemplitAgenda(Cnx, tabAgendas[1])
// Parcours des événements
Evt est un gglEvénement
POUR TOUT Evt DE tabAgendas[1]
Trace(Evt.Titre)
Trace(Evt.Couleur)
Trace(Evt.Notification.Défaut)
Trace(Evt.Notification.Surcharge.Occurrence)
Trace(Evt.Visibilité)
Trace(Evt.Disponibilté)
Trace(Evt.PièceJointe.Occurrence)
POUR TOUT UneNotif DE Evt.Notification.Surcharge
Trace(UneNotif.Méthode)
Trace(UneNotif.NbMinute)
FIN
POUR TOUT UnFichier DE Evt.PièceJointe
Trace(UnFichier.IdFichier)
Trace(UnFichier.Titre)
Trace(UnFichier.URLFichier)
Trace(UnFichier.URLIcone)
Trace(UnFichier.TypeMIME)
FIN
FIN
Remarques

Propriétés spécifiques à la description des variables de type gglSurcharge

Les propriétés suivantes peuvent être utilisées pour manipuler une surcharge :
Nom de la propriétéType manipuléEffet
MéthodeConstante de type chaîneMéthode utilisée pour les notifications :
  • gglNotificationEmail : notification par email.
  • gglNotificationPopup : notification dans une popup.
NbMinuteEntierNombre de minutes avant l’événement permettant de définir le moment où la notification doit être affichée / envoyée.
Ce nombre doit être compris entre 0 et 40320 (40320 = 4 semaines en minutes).
Version minimum requise
  • Version 26
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire