PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Propriétés spécifiques à la description des variables de type gglPièceJointe
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget IOSApple WatchMac CatalystUniversal Windows 10 App
Autres
Procédures stockées
Le type gglPièceJointe permet de définir toutes les caractéristiques avancées d'une pièce jointe à un événement d'un agenda. L'agenda est décrit grâce au type gglAgenda. Cet agenda est utilisé par le service Agenda Google Calendar. Les caractéristiques de cette pièce jointe peuvent être définies et modifiées à l'aide de différentes propriétés WLangage.
Ce type de variable est manipulé via les variables de type gglEvénement.
Remarque : Pour plus de détails sur la déclaration de ce type de variable et l'utilisation des propriétés WLangage, consultez Déclaration d'une variable.
Exemple
// Connexion à Google
Cnx est un gglConnexion
Cnx.Email = "balthazar@gmail.com"
Cnx.MotDePasse = "azerty"
Cnx.NomApplication = "MonAppli-01"
SI GglConnecte(Cnx) = Faux ALORS
Erreur(ErreurInfo())
FIN
...
// Récupération du tableau des agendas disponibles
tabAgendas est un tableau de gglAgenda
tabAgendas = GglListeAgenda(Cnx)
// Récupération de tous les événements du premier agenda
GglRemplitAgenda(Cnx, tabAgendas[1])
// Parcours des événements
Evt est un gglEvénement
POUR TOUT Evt DE tabAgendas[1]
Trace(Evt.Titre)
Trace(Evt.Couleur)
Trace(Evt.Notification.Défaut)
Trace(Evt.Notification.Surcharge.Occurrence)
Trace(Evt.Visibilité)
Trace(Evt.Disponibilté)
Trace(Evt.PièceJointe.Occurrence)
POUR TOUT UneNotif DE Evt.Notification.Surcharge
Trace(UneNotif.Méthode)
Trace(UneNotif.NbMinute)
FIN
POUR TOUT UnFichier DE Evt.PièceJointe
Trace(UnFichier.IdFichier)
Trace(UnFichier.Titre)
Trace(UnFichier.URLFichier)
Trace(UnFichier.URLIcone)
Trace(UnFichier.TypeMIME)
FIN
FIN
Remarques

Propriétés spécifiques à la description des variables de type gglPièceJointe

Les propriétés suivantes peuvent être utilisées pour manipuler une pièce jointe d'un événement :
Nom de la propriétéType manipuléEffet
IdFichierChaîne de caractèresIdentifiant du fichier joint.
Cette propriété est disponible en lecture seulement.
TitreChaîne de caractèresTitre de la pièce jointe.
TypeMIMEChaîne de caractèresType MIME de la pièce jointe.
URLFichierChaîne de caractèresURL du fichier attaché.
URLIconeChaîne de caractèresURL de l'icône associée à la pièce jointe
Cette propriété est disponible en lecture seulement.
Version minimum requise
  • Version 26
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire