PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE


Nouveauté WINDEV 26 !
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget iOSApple WatchCatalystUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
La propriété Détaché permet de savoir si un volet d'un champ Onglet ou d'un champ Ruban est détaché.
Exemple
//  Si le volet 2 du champ Ruban est détaché alors on rend actif le volet suivant
SI RUBAN_Menu[2].Détaché ALORS
RUBAN_Menu = 3
SINON
RUBAN_Menu = 2
FIN
 
// Savoir si un volet d'un champ Onglet est détaché
POUR i = 1 À ONG_Choix.Occurrence
     SI ONG_Choix[i].Détaché ALORS RENVOYER Vrai
FIN
RENVOYER Faux
Syntaxe

Savoir si un volet est détaché Masquer les détails

<Résultat> = <Champ manipulé>.Détaché
<Résultat> : Booléen
  • Vrai si le volet est détaché,
  • Faux dans le cas contraire.
<Champ manipulé> : Nom de champ
Nom volet du champ Onglet ou Ruban à manipuler. La notation suivante doit être utilisée :
<Nom du champ>[Indice de l'élément]
Par exemple :
RUBAN_Menu[2]
Remarques
  • Un volet est détaché s'il est dans une fenêtre libre à coté de la fenêtre où se trouve le champ.
  • Pour pouvoir détacher un volet du champ Onglet, ce volet doit être dynamique.
  • Pour pouvoir détacher un volet d'un champ Ruban, l'option "Volets détachables" doit être cochée dans la fenêtre de description du champ.
Version minimum requise
  • Version 26
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire