PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget IOSApple WatchMac CatalystUniversal Windows 10 App
Autres
Procédures stockées
Permet de connaître ou modifier un champ d'un formulaire HTML présent dans un champ d'affichage HTML.
Exemple
SI HTMLValeurChamp(HTM_Affichage, "LOGIN") <> "" ALORS
HTMLValeurChamp(HTM_Affichage, "LOGIN", RéseauUtilisateur())
FIN
HTMLValeurChamp(HTM_Sites, "input4")
SI ErreurDétectée ALORS
Trace(ErreurInfo()) // ex: Le champ <"input4"> n'existe pas dans la page.
RETOUR
SINON
HTMLValeurChamp(HTM_Sites, "input4", sValeurChamp)
FIN
Syntaxe

Connaître la valeur d'un champ présent dans un formulaire HTML Masquer les détails

<Résultat> = HTMLValeurChamp(<Champ d'affichage HTML> , <Champ de la page>)
<Résultat> : Chaîne de caractères
  • Valeur du champ présent dans le champ d'affichage HTML,
  • Chaîne vide ("") en cas d'erreur (par exemple si le champ n'est pas trouvé dans la page). Dans ce cas, la variable ErreurDétectée vaut Vrai. Il est possible de connaître le détail de l'erreur grâce à la fonction ErreurInfo.
<Champ d'affichage HTML> : Nom de champ
Nom du champ d'affichage HTML manipulé.
<Champ de la page> : Chaîne de caractères
Nom du champ présent dans la page HTML affichée par le champ d'affichage HTML.

Modifier la valeur d'un champ présent dans un formulaire HTML Masquer les détails

HTMLValeurChamp(<Champ d'affichage HTML> , <Champ de la page> , <Valeur>)
<Champ d'affichage HTML> : Nom de champ
Nom du champ d'affichage HTML manipulé.
<Champ de la page> : Chaîne de caractères
Nom du champ présent dans la page HTML affichée par le champ d'affichage HTML. Si le champ n'est pas trouvé, une erreur non fatale est levée.
<Valeur> : Chaîne de caractères
Valeur du champ à modifier.
Remarques
  • Important : Pour que cette fonction puisse s'exécuter dans le contexte de la page HTML affichée dans le champ d'affichage HTML, il est nécessaire que le champ soit accessible en Javascript dans la page. Il ne doit pas y avoir de restrictions d'accès sur cette page.
  • Cette fonction permet de piloter la page Web affichée dans un champ d'affichage HTML.
  • Le champ est recherché par son nom puis par son ID. Le nom du champ (ou son ID) peut être connu en éditant le code source de la page HTML.
  • Attention : les noms HTML sont sensibles à la casse.
Classification Métier / UI : Code UI
Composante : wd280obj.dll
Version minimum requise
  • Version 26
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire