PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget IOSApple WatchMac CatalystUniversal Windows 10 App
Autres
Procédures stockées
Recherche une chaîne de caractères dans un champ Editeur HTML. La recherche ne tient pas compte de la mise en forme de la chaîne de caractères.
Exemple
// Compte le nombre de WINDEV
// (y compris si le WIN est en gras)
nbMot est entier = 0
EditeurHTMLRecherche(EDHTML_MonEditeurHTML, "WINDEV", MotComplet + SansCasse, ...
EditeurHTMLRecherche_Callback)
 
PROCÉDURE INTERNE EditeurHTMLRecherche_Callback(nPos est un entier)
SI nPos = 0 ALORS
// Fin du parcours
Info("Nombre de WINDEV : " + nbMot)
RETOUR
FIN
// Trouvé
nbMot++
FIN
Syntaxe
EditeurHTMLRecherche(<Champ Editeur HTML> , <Texte à rechercher> , <Procédure WLangage> [, <Options> [, <Nombre maximum>]])
<Champ Editeur HTML> : Nom de champ
Nom du champ Editeur HTML manipulé.
<Texte à rechercher> : Chaîne de caractères
Texte à rechercher dans le champ Editeur HTML.
<Procédure WLangage> : Nom de procédure
Procédure WLangage (également nommée "callback") exécutée pour chaque élément trouvé. Cette procédure est de la forme :
PROCEDURE <Nom de la procédure>(nPosition est un entier)
où <nPosition> est un entier correspondant à la position du texte recherché par rapport au texte sans balise. Cette valeur peut être utilisée : A la fin du parcours, <nPos> vaut 0.
<Options> : Constante (ou combinaison de constantes) optionnelle
Options de recherche :
MotCompletRecherche le mot complet (entouré par des caractères de ponctuation ou des espaces).
SansCasseRecherche sans tenir compte de la casse (majuscules/minuscules) et des accents.

Par défaut, la recherche est sensible à la casse : le texte recherché doit avoir la même casse que le texte à trouver. Pour effectuer une recherche ne tenant pas compte de la casse, utilisez la constante SansCasse.
<Nombre maximum> : Entier optionnel
Nombre maximum d'éléments à trouver. Permet de limiter la recherche (par exemple, permet de parcourir uniquement les 5 premiers éléments trouvés).
Classification Métier / UI : Code UI
Composante : wd270obj.dll
Version minimum requise
  • Version 26
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire