PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget IOSApple WatchMac CatalystUniversal Windows 10 App
Autres
Procédures stockées
Procédure WLangage de gestion de la jauge appelée par la fonction zipExtraitRépertoire
Procédure WLangage (également appelée "Callback") utilisée par la fonction zipExtraitRépertoire pour gérer la progression de l'extraction des fichiers dans l'archive.
Exemple
Archive est un zipArchive
// Ouverture d'une archive
SI zipOuvre(Archive, "C:\Archives\Archive.zip") = 0 ALORS
// Extraction du répertoire "Temp" à la racine de l'arborescence des fichiers de l'archive
zipExtraitRépertoire(Archive, "Temp", zipDisque, zipEcrase, ...
zipExtraitRépertoire_Callback, zipExtraitRépertoire_CallbackJauge)
FIN
 
// Cette procédure permet de gérer la jauge.
PROCÉDURE INTERNE zipExtraitRépertoire_CallbackJauge(FichierEnCours est une chaîne,
AvancementGlobal est un entier, AvancementFichier est un entier)
SI AvancementGlobal < 100 ALORS
Jauge(AvancementGlobal, 100, FichierEnCours)
SINON
Jauge()
FIN
FIN
Syntaxe
zipExtraitRépertoire_CallbackJauge(<Fichier en cours> , <Pourcentage d'avancement global> , <Pourcentage d'avancement du fichier>)
<Fichier en cours> : Chaîne de caractères
Nom du fichier en cours de traitement.
<Pourcentage d'avancement global> : Entier
Pourcentage d'avancement de l'extraction des fichiers dans l'archive.
<Pourcentage d'avancement du fichier> : Entier
Pourcentage d'avancement de l'extraction du fichier en cours dans l'archive.
Remarques
Si vous manipulez une archive au format 7z, seul le paramètre <Pourcentage d'avancement global> est renseigné. Le paramètre <Pourcentage d'avancement du fichier> aura la même valeur.
Composante : wd270.dll
Version minimum requise
  • Version 26
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire