PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Codes d'erreur
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget IOSApple WatchMac CatalystUniversal Windows 10 App
Autres
Procédures stockées
Procédure WLangage de gestion des erreurs appelée par la fonction zipExtraitRépertoire
Procédure WLangage (également appelée "Callback") appelée si une erreur est rencontrée lors de l'extraction des fichiers par la fonction zipExtraitRépertoire.
Exemple
Archive est un zipArchive
// Ouverture d'une archive
SI zipOuvre(Archive, "C:\Archives\Archive.zip") = 0 ALORS
// Extraction du répertoire "Temp" à la racine de l'arborescence des fichiers de l'archive
zipExtraitRépertoire(Archive, "Temp", zipDisque, zipExtraitRépertoire_CallbackErreur)
FIN
 
PROCÉDURE INTERNE zipExtraitRépertoire_CallbackErreur(CodeErreur est un entier, ...
NomFichier est une chaîne)
SI CodeErreur = 1 ALORS
RENVOYER zipAnnule
FIN
FIN
Syntaxe
<Résultat> = zipExtraitRépertoire_CallbackErreur(<Code erreur> , <Nom du fichier>)
<Résultat> : Constante de type Entier
La procédure peut renvoyer une des constantes suivantes :
zipAnnuleAnnule l'extraction des fichiers présents dans l'archive.
zipIgnoreIgnore le fichier en erreur.
zipRecommenceRetente l'extraction du fichier.
<Code erreur> : Entier
Code de l'erreur rencontrée lors de l'extraction du fichier.
<Nom du fichier> : Chaîne de caractères
Chemin du fichier qui va être traité par la fonction zipExtraitRépertoire.
Remarques

Codes d'erreur

Les codes d'erreur retournés sont les suivants :
  • 1 : Le chemin passé en paramètre n'existe pas.
  • 2 : Accès interdit : l'utilisateur n'a pas les droits nécessaires.
  • 3 : L'archive est corrompue.
  • 4 : Le chemin n'existe pas dans l'archive.
  • 6 : Les fichiers des sous-archives ne sont pas dans l'ordre (cas d'une extraction dans une archive multi-parties).
  • 21 : Le mot de passe spécifié n'est pas correct.
Le message correspondant au code d'erreur peut être connu grâce à la fonction zipMsgErreur.
Remarques :
  • LinuxUniversal Windows 10 AppiPhone/iPadWidget IOSMac Catalyst Seules les archives au format ZIP, TAR et TGZ (TAR.GZ) sont disponibles.
  • AndroidWidget Android Le format CAB n'est pas disponible.
Composante : wd270.dll
Version minimum requise
  • Version 26
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire