PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

PV


WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget IOSApple WatchMac CatalystUniversal Windows 10 App
Autres
Procédures stockées
Renvoie la liste des synonymes utilisés par un index full-text.
Exemple
// Récupère l'ensemble des mots synonymes
soit sEnsembleSynonyme = FichierDeDonnées.ListeSynonyme(MonIndexFullText)
// Pour chaque groupe de mots synonymes
POUR TOUTE CHAÎNE sListeSynonyme DE sEnsembleSynonyme SÉPARÉE PAR RC
soit sChaîne = "Les mots suivants sont synonymes : "
// Extrait chaque synonyme
POUR TOUTE CHAÎNE sSynonyme DE sListeSynonyme SÉPARÉE PAR TAB
// Ajoute le mot à la chaîne
sChaîne += sSynonyme + " "
FIN
Trace(sChaîne)
FIN
Syntaxe
<Résultat> = <Source>.ListeSynonyme(<Index full-text> [, <Chemin du WDD> [, <Mot de passe du WDD>]])
<Résultat> : Chaîne de caractères
Liste des synonymes définis pour l'index full-text spécifié dans le fichier de données spécifié. Cette liste est de la forme :
<Mot 1> + TAB + <Synonyme 1A> + TAB + <Synonyme 1B> + RC + ...
<Mot 2> + TAB + <Synonyme 2> + ... + RC + ...
<Mot N> + TAB + <Synonyme N>
Dans cette liste :
  • Les synonymes sont séparés par une tabulation (TAB).
  • Les différents groupes de synonymes sont séparés par un Retour Chariot (RC).
Remarques :
  • Les mots peuvent avoir été mis en majuscules si l'index full-text est aussi insensible à la casse ou les accents retirés si l'index full-text est insensible à l'accentuation.
  • Les mots possédant une longueur plus petite que la longueur minimale spécifiée pour l'index full-text peuvent ne pas apparaître dans cette liste.
<Source> : Type correspondant à la source spécifiée
Nom du fichier de données contenant l'index full-text.
<Index full-text> : Chaîne de caractères
Nom de l'index full-text manipulé.
<Chemin du WDD> : Chaîne de caractères optionnelle
Chemin complet de l'analyse (c'est-à-dire du ficher .WDD) dans laquelle le fichier de données est décrit. Si ce paramètre n'est pas précisé ou est égal à une chaîne vide (""), le fichier de données est recherché dans l'analyse en cours.
<Mot de passe du WDD> : Chaîne de caractères optionnelle
Mot de passe défini pour l'analyse. Si aucun mot de passe n'est défini, ce paramètre doit être égal à une chaîne vide ("").
Composante : wd280hf.dll
Version minimum requise
  • Version 25
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire