PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

Nouveauté WINDEV, WEBDEV, WINDEV Mobile 25 !
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget iOSApple WatchCatalystUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Renvoie la liste de tous les pays ou des pays d'un continent donné selon la norme ISO 3166-1.
Remarque : La liste des pays fournie est celle définie par la norme ISO 3166-1 au 15/10/2019.
Exemple
// Initialisation de la liste des pays
tabListePays est un tableau de Pays = PaysListe()
POUR TOUT oPays DE tabListePays
ListeAjoute(LISTE_ListePays, oPays..Nom)
FIN
 
// Remplit un champ Table avec la liste de tous les pays
// (ainsi que toutes les informations sur chaque pays).
tabListePays est un tableau de Pays = PaysListe()
POUR TOUT oPays DE tabListePays
TableAjouteLigne(TABLE_Pays, oPays..Nom, oPays..CodeISO2, oPays..CodeISO3, ...
oPays..CodeISONum, oPays..Continent..Nom, oPays..Drapeau, ...
oPays..Nation, oPays..PréfixeNuméroDeTéléphone)
FIN
// Cet exemple montre comment remplir un champ Combo avec la liste des pays européens.
// Le Libellé du pays est affiché.
// Le code numérique du pays est mémorisé.
// Le code du pays est mémorisé et récupéré grâce à la fonction gLien.
//---------------------------------------------------------------
// -- Initialisation du champ Combo
tabListePays est un tableau de Pays = PaysListe(continentEurope)
gLienActive(COMBO_Pays, Vrai)
POUR TOUT oPays DE tabListePays
ListeAjoute(COMBO_Pays, oPays..Nom + gLien(oPays..CodeISO3))
FIN
//--------------------------------------------------------------
// -- Sélection d'une ligne du champ Combo
Info("Le nom du pays est : " + COMBO_Pays..ValeurAffichée, ...
"Le code pays est : " + COMBO_Pays..ValeurMémorisée)
Syntaxe
<Résultat> = PaysListe([<Continent>])
<Résultat> : Tableau de variable de type Pays
Tableau de variables de type Pays contenant la liste des pays.
<Continent> : Chaîne de caractères optionnelle, variable de type Continent optionnelle ou constante optionnelle
Continent pour lequel les pays doivent être listés. Ce paramètre peut correspondre à :
  • une variable de type Continent,
  • le libellé du continent (en français, anglais ou espagnol).
  • une constante identifiant le continent  (ou code continent sur 2 caractères) :
    continentAfriqueAfrique (la constante vaut "AF").
    continentAmériqueNordAmérique du Nord (la constante vaut "NA").
    continentAmériqueSudAmérique du Sud (la constante vaut "SA").
    continentAntarctiqueAntarctique (la constante vaut "AN").
    continentAsieAsie (la constante vaut "AS").
    continentEuropeEurope (la constante vaut "EU").
    continentOcéanieOcéanie (la constante vaut "OC").
Si ce paramètre n'est pas précisé, le résultat contient la liste de tous les pays.
Classification Métier / UI : Code métier
Composante : wd250std.dll
Version minimum requise
  • Version 25
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire