PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

Nouveauté WINDEV 25 !
  • Propriétés spécifiques à la description des variables de type MasqueDeSaisie
  • Utilisation
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget iOSApple WatchCatalystUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Le type MasqueDeSaisie permet de définir toutes les caractéristiques avancées d'un masque de saisie personnalisé. Les caractéristiques de ce masque de saisie personnalisé peuvent être définies et modifiées à l'aide de différentes propriétés WLangage.
Remarque : Pour plus de détails sur la déclaration de ce type de variable et l'utilisation des propriétés WLangage, consultez Déclaration d'une variable.
Exemple
m_sMasque est chaîne = "99 99 99 99 99"
MasquePerso est un MasqueDeSaisie
MasquePerso..FormateEnSaisie = FormateEnSaisie
MasquePerso..ValideEnSaisie = ValideEnSaisie
MasquePerso..ValideEnSortie = ValideEnSortie
MasquePerso..FormateEnSortie = FormateEnSortie
MasquePerso..FormateEnEntrée = FormateEnEntrée
 
SAI_Téléphone..MasqueSaisie = MasquePerso
 
PROCÉDURE INTERNE FormateEnSaisie(LOCAL sTexteAvant chaîne, LOCAL nCurseurAvant entier, ...
LOCAL nFinCurseurAvant entier, sTexteApres chaîne, nCurseurApres entier, ...
nFinCurseurApres entier)
SI Taille(sTexteAvant) > Taille(sTexteApres) ALORS RETOUR
//Ne rien faire si on est en train d'effacer
// si on est a la fin
SI nFinCurseurApres = Taille(sTexteApres)+1 ALORS
// on met un " " si c'est ce qu'il faut a cette position
SI Milieu(m_sMasque, nFinCurseurApres, 1) = " " ALORS
sTexteApres += " "
nFinCurseurApres ++
nCurseurApres = nFinCurseurApres
FIN
FIN
FIN
 
PROCÉDURE INTERNE ValideEnSaisie(sTexte chaîne) : booléen
RENVOYER VérifieExpressionRégulière(sTexte , "[0-9 ]*")
FIN
 
PROCÉDURE INTERNE ValideEnSortie(sTexte chaîne) : booléen
SI Taille(sTexte) < 3 ALORS
ToastAffiche("Au moins 3 caractères")
RENVOYER Faux
FIN
RENVOYER Vrai
FIN
 
PROCÉDURE INTERNE FormateEnSortie(sTexte_INOUT chaîne)
FormateChaîneEnNuméroTéléphone(sTexte_INOUT)
FIN
 
PROCÉDURE INTERNE FormateEnEntrée(sTexte_INOUT chaîne)
FormateChaîneEnNuméroTéléphone(sTexte_INOUT)
FIN
 
PROCÉDURE INTERNE FormateChaîneEnNuméroTéléphone(sTexte_INOUT chaîne)
// on groupe les chiffres comme dans le masque
sTexte_INOUT = Remplace(sTexte_INOUT," ","")
sResultat est une chaîne
nPosSrc est un entier = 1
POUR I = 1 _À_ Taille(m_sMasque)
// selon le caractère dans le masque
SELON Milieu( m_sMasque, I, 1)
CAS " "
sResultat += " "
AUTRE CAS
// garde le caractère saisi
sResultat += Milieu(sTexte_INOUT, nPosSrc, 1)
nPosSrc++
FIN
FIN
sTexte_INOUT = sResultat
FIN
Remarques

Propriétés spécifiques à la description des variables de type MasqueDeSaisie

Les propriétés suivantes peuvent être utilisées pour manipuler un masque de saisie personnalisé :
Nom de la propriétéType manipuléEffet
FormateEnEntréeProcédure WLangageNom de la procédure WLangage qui transforme le texte affiché vers le texte en saisie.
Cette procédure est de la forme :
PROCEDURE <Nom de la procédure>(<Texte> chaîne)
où <Texte> correspond au texte à manipuler.
Si cette propriété n'est pas renseignée, aucune transformation n'est effectuée.
FormateEnSaisieProcédure WLangageNom de la procédure WLangage qui transforme le texte durant sa saisie.
Cette procédure est de la forme :
PROCEDURE <Nom de la procédure>(LOCAL <Texte avant> chaîne,
LOCAL <Curseur avant> entier,
LOCAL <Fin Curseur avant> entier,
<Texte après> chaîne, <Curseur après> entier,
<Fin Curseur après> entier)
où :
  • <Texte avant> correspond au texte avant la saisie.
  • <Curseur avant> correspond à la position du curseur avant la saisie.
  • <Fin curseur avant> correspond à la position de fin du curseur avant la saisie.
  • <Texte après> correspond au texte après la saisie.
  • <Curseur après> correspond à la position du curseur après la saisie.
  • <Fin curseur après> correspond à la position de fin du curseur après la saisie.
Si cette propriété n'est pas renseignée, aucune transformation n'est effectuée.
FormateEnSortieProcédure WLangageNom de la procédure WLangage qui transforme le texte en saisie vers le texte affiché.
Cette procédure est de la forme :
PROCEDURE <Nom de la procédure>(<Texte> chaîne)
où <Texte> correspond au texte à manipuler.
Si cette propriété n'est pas renseignée, aucune transformation n'est effectuée.
ValideEnSaisieProcédure WLangageNom de la procédure WLangage qui vérifie la saisie en cours. Cette procédure renvoie Faux si le texte en cours de saisie contient des caractères invalides.
Cette procédure est de la forme :
PROCEDURE <Nom de la procédure>(<Texte> chaîne)
où <Texte> correspond au texte à manipuler.
Si cette propriété n'est pas renseignée, aucune transformation n'est effectuée.
ValideEnSortieProcédure WLangageNom de la procédure WLangage qui vérifie la saisie effectuée (lorsque tous les caractères ont été saisis). Cette procédure renvoie Faux si le texte qui a été saisi contient des caractères invalides.
Cette procédure est de la forme :
PROCEDURE <Nom de la procédure>(<Texte> chaîne)
où <Texte> correspond au texte à manipuler.
Si cette propriété n'est pas renseignée, aucune transformation n'est effectuée.

Remarque : Ces propriétés peuvent être utilisées en utilisant une des deux syntaxes suivantes :
  • <Nom de la variable>..<Nom de la propriété>
  • <Nom de la variable>.<Nom de la propriété>

Utilisation

  • Une variable de type MasqueDeSaisie peut être affectée à la propriété ..MasqueSaisie pour avoir un contrôle personnalisé sur chaque évènement lié a la gestion du masque d’un champ de saisie.
  • Les fonctions MasqueNuméroDeTéléphone et MasqueCodePostal manipulent des variables de type MasqueDeSaisie.
Version minimum requise
  • Version 25
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire