PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Propriétés spécifiques à la description des variables de type MasqueDeSaisie
  • Utilisation
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget IOSApple WatchMac CatalystUniversal Windows 10 App
Autres
Procédures stockées
Le type MasqueDeSaisie permet de définir toutes les caractéristiques avancées d'un masque de saisie personnalisé. Les caractéristiques de ce masque de saisie personnalisé peuvent être définies et modifiées à l'aide de différentes propriétés WLangage.
Remarque : Pour plus de détails sur la déclaration de ce type de variable et l'utilisation des propriétés WLangage, consultez Déclaration d'une variable.
Versions 26 et supérieures
Linux Cette fonction est désormais disponible pour les applications WINDEV sous Linux.
Android Cette fonction est désormais disponible pour les applications Android.
Widget Android Cette fonction est désormais disponible en mode Widget Android.
iPhone/iPad Cette fonction est désormais disponible pour les applications iPhone/iPad.
Nouveauté 26
Linux Cette fonction est désormais disponible pour les applications WINDEV sous Linux.
Android Cette fonction est désormais disponible pour les applications Android.
Widget Android Cette fonction est désormais disponible en mode Widget Android.
iPhone/iPad Cette fonction est désormais disponible pour les applications iPhone/iPad.
Linux Cette fonction est désormais disponible pour les applications WINDEV sous Linux.
Android Cette fonction est désormais disponible pour les applications Android.
Widget Android Cette fonction est désormais disponible en mode Widget Android.
iPhone/iPad Cette fonction est désormais disponible pour les applications iPhone/iPad.
Exemple
m_sMasque est chaîne = "99 99 99 99 99"
MasquePerso est un MasqueDeSaisie
MasquePerso.FormateEnSaisie = FormateEnSaisie
MasquePerso.ValideEnSaisie = ValideEnSaisie
MasquePerso.ValideEnSortie = ValideEnSortie
MasquePerso.FormateEnSortie = FormateEnSortie
MasquePerso.FormateEnEntrée = FormateEnEntrée
MasquePerso.FormateEnAffectation = FormateEnAffectation
MasquePerso.VérifieSiSaisieValide = VérifieSiSaisieValide
 
SAI_Téléphone.MasqueSaisie = MasquePerso
 
PROCÉDURE INTERNE FormateEnSaisie(LOCAL sTexteAvant est une chaîne,
LOCAL nCurseurAvant est un entier, ...
LOCAL nFinCurseurAvant est un entier, ...
sTexteApres est une chaîne, ...
nCurseurApres est un entier, ...
nFinCurseurApres entier)
SI Taille(sTexteAvant) > Taille(sTexteApres) ALORS RETOUR
//Ne rien faire si on est en train d'effacer
// si on est a la fin
SI nFinCurseurApres = Taille(sTexteApres) + 1 ALORS
// on met un " " si c'est ce qu'il faut a cette position
SI Milieu(m_sMasque, nFinCurseurApres, 1) = " " ALORS
sTexteApres += " "
nFinCurseurApres ++
nCurseurApres = nFinCurseurApres
FIN
FIN
FIN
 
PROCÉDURE INTERNE ValideEnSaisie(sTexte est une chaîne) : booléen
RENVOYER VérifieExpressionRégulière(sTexte, "[0-9 ]*")
FIN
 
PROCÉDURE INTERNE VérifieSiSaisieValide(sTexte est une chaîne) : booléen
RENVOYER ValideEnSaisie(sTexte) _ET_ Taille(sTexte) >= 3
FIN
 
PROCÉDURE INTERNE FormateEnAffectation(sTexte_INOUT est une chaîne)
FormateChaîneEnNuméroTéléphone(sTexte_INOUT)
FIN
 
PROCÉDURE INTERNE ValideEnSortie(sTexte est une chaîne) : booléen
SI Taille(sTexte) < 3 ALORS
ToastAffiche("Au moins 3 caractères")
RENVOYER Faux
FIN
RENVOYER Vrai
FIN
 
PROCÉDURE INTERNE FormateEnSortie(sTexte_INOUT est une chaîne)
FormateChaîneEnNuméroTéléphone(sTexte_INOUT)
FIN
 
PROCÉDURE INTERNE FormateEnEntrée(sTexte_INOUT est une chaîne)
FormateChaîneEnNuméroTéléphone(sTexte_INOUT)
FIN
 
PROCÉDURE INTERNE FormateChaîneEnNuméroTéléphone(sTexte_INOUT est une chaîne)
// on groupe les chiffres comme dans le masque
sTexte_INOUT = Remplace(sTexte_INOUT," ","")
sResultat est une chaîne
nPosSrc est un entier = 1
POUR I = 1 _À_ Taille(m_sMasque)
// selon le caractère dans le masque
SELON Milieu( m_sMasque, I, 1)
CAS " "
sResultat += " "
AUTRE CAS
// garde le caractère saisi
sResultat += Milieu(sTexte_INOUT, nPosSrc, 1)
nPosSrc++
FIN
FIN
sTexte_INOUT = sResultat
FIN
Remarques

Propriétés spécifiques à la description des variables de type MasqueDeSaisie

Les propriétés suivantes peuvent être utilisées pour manipuler un masque de saisie personnalisé :
Nom de la propriétéType manipuléEffet
Versions 26 et supérieures
FormateEnAffectation
Nouveauté 26
FormateEnAffectation
FormateEnAffectation
Procédure WLangageNom de la procédure WLangage qui transforme le texte affecté par programmation vers le texte à afficher.
Cette procédure est de la forme :
PROCEDURE <Nom de la procédure>(<Texte> chaîne)
où <Texte> correspond au texte à manipuler.
Si cette propriété n'est pas renseignée, aucune transformation n'est effectuée.
FormateEnEntréeProcédure WLangageNom de la procédure WLangage qui transforme le texte affiché vers le texte en saisie.
Cette procédure est de la forme :
PROCEDURE <Nom de la procédure>(<Texte> chaîne)
où <Texte> correspond au texte à manipuler.
Si cette propriété n'est pas renseignée, aucune transformation n'est effectuée.
FormateEnSaisieProcédure WLangageNom de la procédure WLangage qui transforme le texte durant sa saisie.
Cette procédure est de la forme :
PROCEDURE <Nom de la procédure>(LOCAL <Texte avant> chaîne,
LOCAL <Curseur avant> entier,
LOCAL <Fin Curseur avant> entier,
<Texte après> chaîne, <Curseur après> entier,
<Fin Curseur après> entier)
où :
  • <Texte avant> correspond au texte avant la saisie.
  • <Curseur avant> correspond à la position du curseur avant la saisie.
  • <Fin curseur avant> correspond à la position de fin du curseur avant la saisie.
  • <Texte après> correspond au texte après la saisie.
  • <Curseur après> correspond à la position du curseur après la saisie.
  • <Fin curseur après> correspond à la position de fin du curseur après la saisie.
Si cette propriété n'est pas renseignée, aucune transformation n'est effectuée.
FormateEnSortieProcédure WLangageNom de la procédure WLangage qui transforme le texte en saisie vers le texte affiché.
Cette procédure est de la forme :
PROCEDURE <Nom de la procédure>(<Texte> chaîne)
où <Texte> correspond au texte à manipuler.
Si cette propriété n'est pas renseignée, aucune transformation n'est effectuée.
ValideEnSaisieProcédure WLangageNom de la procédure WLangage qui vérifie la saisie en cours. Cette procédure renvoie Faux si le texte en cours de saisie contient des caractères invalides.
Cette procédure est de la forme :
PROCEDURE <Nom de la procédure>(<Texte> chaîne)
où <Texte> correspond au texte à manipuler.
Si cette propriété n'est pas renseignée, aucune transformation n'est effectuée.
ValideEnSortieProcédure WLangageNom de la procédure WLangage qui vérifie la saisie effectuée (lorsque tous les caractères ont été saisis). Cette procédure renvoie Faux si le texte qui a été saisi contient des caractères invalides.
Versions 26 et supérieures
Cette procédure sera appelée en sortie de champ uniquement si la validation de la saisie est en mode bloquant. Pour plus de détails, consultez Saisie obligatoire ou invalide dans WINDEV.
Nouveauté 26
Cette procédure sera appelée en sortie de champ uniquement si la validation de la saisie est en mode bloquant. Pour plus de détails, consultez Saisie obligatoire ou invalide dans WINDEV.
Cette procédure sera appelée en sortie de champ uniquement si la validation de la saisie est en mode bloquant. Pour plus de détails, consultez Saisie obligatoire ou invalide dans WINDEV.
Cette procédure est de la forme :
PROCEDURE <Nom de la procédure>(<Texte> chaîne)
où <Texte> correspond au texte à manipuler.
Si cette propriété n'est pas renseignée, aucune transformation n'est effectuée.
Versions 26 et supérieures
VérifieSiSaisieValide
Nouveauté 26
VérifieSiSaisieValide
VérifieSiSaisieValide
Procédure WLangageNom de la procédure WLangage appelée par les fonctions SaisieInvalideDétecte et SaisieInvalideListeChamp pour déterminer si le texte saisi est valide.
Cette procédure est de la forme :
PROCEDURE <Nom de la procédure>(<Texte> chaîne)
où <Texte> correspond au texte à manipuler.
Si cette propriété n'est pas renseignée, aucune vérification n'est effectuée.

Utilisation

  • Une variable de type MasqueDeSaisie peut être affectée à la propriété MasqueSaisie pour avoir un contrôle personnalisé sur chaque événement lié a la gestion du masque d'un champ de saisie.
  • Les fonctions MasqueNuméroDeTéléphone et MasqueCodePostal manipulent des variables de type MasqueDeSaisie.
Version minimum requise
  • Version 25
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire