PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget iOSApple WatchCatalystUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Recherche une chaîne de caractères dans l’ensemble d'une variable de type Document.
Exemple
MonDocument est un Document
 
tabFragments est tableau de docFragments = MonDocument.Recherche("%NomClient%")
// Remplacement de tous les "%NomClient%" par le nom du client
POUR TOUT f DE tabFragments
f..Texte = Client.Nom
FIN
MonDocument est un Document
 
// Recherche du mot "BEAUGRAND" dans le texte
// Sélectionne uniquement le premier trouvé pour changer sa couleur
tabFragments est tableau de docFragments = MonDocument.Recherche("BEAUGRAND")
SI tabFragments..Occurrence >= 1 ALORS
// Positionnement du curseur au début du premier mot trouvé
MonDocument..Curseur = tabFragments[1]..PositionDébut
// Calcul de la longueur de la sélection
MonDocument..LongueurSélection = ...
tabFragments[1]..PositionFin - tabFragments[1]..PositionDébut+1
// Modification de la couleur du texte
tabFragments[1]..MiseEnForme..CouleurTexte = RougePastel
SORTIR
FIN
Syntaxe
<Résultat> = <Document>.Recherche(<Texte à rechercher> [, <Options>])
<Résultat> : Tableau de variables de type docFragment
Tableau de variables de type docFragment correspondant à l'ensemble des fragments du document dans lequel le texte recherché a été trouvé.
<Document> : Variable de type Document
Nom de la variable de type Document à manipuler.
<Texte à rechercher> : Chaîne de caractères (avec guillemets)
Texte à rechercher dans le document.
<Options> : Constante (ou combinaison de constantes) optionnelle
Options de recherche :
MotCompletRecherche le mot complet (entouré par des caractères de ponctuation ou des espaces).
SansCasseRecherche sans tenir compte de la casse (majuscules/minuscules) et des accents.

Par défaut, la recherche est sensible à la casse : le texte recherché doit avoir la même casse que le texte à trouver. Pour effectuer une recherche ne tenant pas compte de la casse, utilisez la constante SansCasse.
Classification Métier / UI : Code UI
Composante : wd250mdl.dll
Version minimum requise
  • Version 24
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire