PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Présentation
  • Imprimer le corps
  • Imprimer une rupture
  • Sauter des pages au besoin
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget iOSApple WatchCatalystUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Personnaliser un script d'impression
Avertissement
A partir de la version 25, cette fonctionnalité n'est plus disponible. En effet, les états peuvent désormais être imprimés au format PDF depuis une application Android.
Présentation
Voici quelques conseils et exemples d'utilisation des différentes procédures générées dans un script d'impression.
Imprimer le corps
La procédure interne "iImprime_CORPS" doit être appelée dans la boucle de parcours de la source de données.
Il est également nécessaire de modifier cette procédure Interne "iImprime_CORPS" pour imprimer les données de la source de données.
POUR TOUT Client
// Impression du corps
iPosY(iPosY() + 12.912000)
iImprime_CORPS()
FIN
Imprimer une rupture
Pour imprimer une rupture il est nécessaire de gérer la condition de rupture dans la boucle de parcours de la source de données.
POUR TOUT Client
// Gestion de la rupture
SI Client.Société <> sSociétéPrécédente ALORS
// Imprime le bas de rupture (si besoin)
iImprime_BAS_RUPTURE()

// Imprime le haut de rupture
iImprime_DEBUT_RUPTURE1()

FIN

// Impression du corps
iPosY(iPosY() + 12.912000)
iImprime_CORPS()

FIN
Sauter des pages au besoin
Pour gérer les états multipages, il y a plusieurs solutions :
  • La taille des blocs (bas de page, corps, haut et bas de rupture si besoin) est fixe (Aucun champ auto-extensible).
  • La taille des blocs peut être variable (des champs auto-exensibles sont présents).
Si la taille est fixe, il suffit de vérifier que la somme des hauteurs des blocs à imprimer est inférieure à la taille restante dans la page.
Vous pouvez calculer la taille restante avec la fonction iHauteurPage en retirant la position actuelle (fonction iPosY).
Si la taille est variable, vous pouvez utiliser la fonction iHauteurTexte pour calculer la hauteur d'un champ.
Attention : Pensez à tenir compte des marges que vous souhaitez dans vos calculs.
POUR TOUT Client
// Gestion de la rupture
SI Client.Société <> sSociétéPrécédente ALORS
// Imprime le bas de rupture (si besoin)
iImprime_BAS_RUPTURE()

// Imprime le haut de rupture
iImprime_DEBUT_RUPTURE1()

FIN

// Impression du corps
iPosY(iPosY() + 12.912000)
iImprime_CORPS()

// On vérifie que la hauteur restante est bien supérieure à
// 20 (hauteur du bloc corps) + 15 (hauteur du bas de page)  + 20 (marge basse)
SI iHauteurPage() - iPosY()  < 20 + 15 + 20 ALORS
iImprime_BASDEPAGE()

iSautePage()

iImprime_HAUTDEPAGE()

FIN


FIN
Version minimum requise
  • Version 24
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire