PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Manipuler un tableau par programmation
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Insère un tableau dans un champ Traitement de texte.
Exemple
// Insère un tableau à la position 1 de taille 3x3
TT_Tableau.InsèreTableau(1, 3, 3)
// Insère un tableau à la position du curseur de taille 3 colonnes et 2 lignes
TT_Tableau.InsèreTableau(TT_Tableau..Curseur, 3, 2)
Syntaxe
<Résultat> = <Champ Traitement de texte>.InsèreTableau(<Position> [, <Nombre de colonnes> [, <Nombre de lignes>]])
<Résultat> : Variable de type docFragment
Versions 24 et supérieures
Variable de type docFragment contenant le fragment inséré.
Nouveauté 24
Variable de type docFragment contenant le fragment inséré.
Variable de type docFragment contenant le fragment inséré.
<Champ Traitement de texte> : Nom de champ
Nom du champ Traitement de texte à manipuler.
<Position> : Entier
Position à laquelle le tableau doit être inséré. Cette position est exprimée en nombre de caractères.
<Nombre de colonnes> : Entier optionnel
Nombre de colonnes du tableau. Par défaut, ce paramètre correspond à 1.
<Nombre de lignes> : Entier optionnel
Nombre de lignes du tableau. Par défaut, ce paramètre correspond à 1.
Remarques

Manipuler un tableau par programmation

Un tableau présent dans un document de type Traitement de texte peut être manipulé avec les fonctions de gestion des tableaux du WLangage.
Quelques exemples :
// Récupération du document
MonDocument est un Document <- TT_ExempleTT
// Insère un tableau à la position 1 de taille 3x3
TT_ExempleTT.InsèreTableau(1, 3, 3)
 
// Définition d'un fragment correspondant au tableau
f est un TT_ExempleTT..Valeur.Fragment(TT_ExempleTT..Curseur, 0)
 
soit para <- f..Paragraphe[1]
SI para..Tableau = Null ALORS
RETOUR
FIN
 
doc est un Document <- TT_ExempleTT..Valeur
 
// Ajoute une ligne au tableau
nIndice est un entier = Ajoute(para..Tableau..Lignes)
 
// Saisie dans la cellule 2,2
para.Tableau..Cellules[2,2]..Contenu..Texte = "Je suis dans la cellule 2,2"
 
// Supprime la ligne 3
Supprime(para..Tableau..Lignes, 3)
 
// Supprime la colonne 3
Supprime(para..Tableau..Colonnes, 3)
 
// Supprime le tableau entier où se trouve le curseur
Supprime(doc..Paragraphe, para..IndiceParagraphe)
Exemple de création d'un tableau dans un document avec le contenu d'un champ Table :
// Une fenêtre contient un champ Table mémoire nommé TABLE_Démo
// et un champ Traitement de texte nommé TT_Démo
// Le code suivant ajoute un tableau dans le champ Traitement de texte avec :
// - en première ligne du tableau, le titre des colonnes du champ Table,
// - le contenu du champ Table dans les lignes suivantes du tableau.
 
MonDoc est un Document
cTable est un Champ <- TABLE_Démo
pCol est un Champ
 
FragmentDeb est un MonDoc.docFragment(1)
FragmentDeb..MiseEnForme..PoliceTaille = 24
FragmentDeb..MiseEnForme..CouleurTexte = RougeFoncé
FragmentDeb..Texte = "Tableau dans TTX avec " + cTable..Libellé + RC + RC
 
// Insertion du tableau dans le document en mémoire ...
MonDoc.DocInsèreTableau(20, TableOccurrence(cTable, toColonne), cTable..Occurrence + 1)
 
POUR TOUT para DE MonDoc..Paragraphe
SI para..Tableau <> Null ALORS
// Pour toutes les colonnes du champ table ...
POUR nColonne = 1 _À_ TableOccurrence(cTable, toColonne)
 
// Première ligne du tableau contient le titre des colonnes
pCol <- TableEnumèreColonne(cTable, nColonne)
para..Tableau..Cellules[1, nColonne]..Contenu..Texte = pCol..Libellé
 
// Remplissage de toutes les lignes de cette colonne
POUR nLigne = 1 _À_ cTable..Occurrence
para..Tableau..Cellules[nLigne+1, nColonne]..Contenu..Texte = pCol[nLigne]
FIN
FIN
SORTIR
FIN
FIN
 
// Document en mémoire affecté au champ Traitement de texte
TT_Démo = MonDoc
Composante : wd240mdl.dll
Version minimum requise
  • Version 23
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire