PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Conditions d'utilisation
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget iOSApple WatchCatalystUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Enumère les ruptures d'un champ Table.
Exemple
// Liste les ruptures de TABLE_MaTable
sNomRupture est chaîne
bPosition est un booléen
nNumCol est un entier
 
soit i = 1
sDesc est une chaîne = TABLE_MaTable.EnumèreRupture(i)
TANTQUE sDesc <> ""
sNomRupture = ExtraitChaîne(sDesc, 1, TAB)
bPosition = ExtraitChaîne(sDesc, 2, TAB)
nNumCol = ExtraitChaîne(sDesc, 3, TAB)
  SI {sNomRupture, indChamp}..Visible ALORS
Trace(sNomRupture, bPosition, nNumCol)
FIN
// Rupture suivante
i++
sDesc = TABLE_MaTable.EnumèreRupture(i)
 
FIN
Syntaxe
<Résultat> = <Champ Table>.EnumèreRupture(<Indice de la rupture>)
<Résultat> : Chaîne de caractères
  • Description de la rupture pour l'indice spécifié. Cette description est de la forme :
    <Rupture> + TAB + <Position de la rupture>
    La position de la rupture peut être 1 (haut de rupture) ou 0 (bas de rupture).
    Description de la rupture pour l'indice spécifié. Cette description est de la forme :
    <Rupture> + TAB + <Position de la rupture> + TAB + <Numéro de la colonne>
    où :
    • <Rupture> : Nom de la rupture.
    • <Position de la rupture> : 1 pour un haut de rupture et 0 pour un bas de rupture.
    • <Numéro de la colonne> : Numéro de la colonne qui provoque la rupture.
  • Chaîne vide ("") si le champ Table ne contient pas de rupture ou si le paramètre est égal au nombre de ruptures du champ Table + 1.
<Champ Table> : Nom de champ
Nom du champ Table à manipuler.
<Indice de la rupture> : Entier
Indice de la rupture recherchée, compris entre 1 et le nombre de ruptures du champ Table + 1.
Si ce paramètre est supérieur au nombre de ruptures du champ Table, la fonction renvoie une chaîne vide ("").
Remarques

Conditions d'utilisation

La fonction <Table>.EnumèreRupture peut être utilisée indifféremment sur un champ Table fichier ou mémoire.
Composante : wd250obj.dll
Version minimum requise
  • Version 23
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire