PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE


WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget IOSApple WatchMac CatalystUniversal Windows 10 App
Autres
Procédures stockées
<Source>.DésactiveFiltreAuto (Fonction)
En anglais : <Source>.DeactivateAutoFilter
Connecteurs Natifs (Accès Natifs)Disponible uniquement avec ce type de connexion
Désactive un filtre automatique sur les fichiers de données reliés lors du parcours d'un fichier XML. Ce filtre a été activé grâce à la fonction <Source>.ActiveFiltreAuto.
Attention : Cette fonction est disponible uniquement pour l'Accès Natif XML.
Exemple
// Activation de tous les filtres auto possibles du fichier de données Client
Client.ActiveFiltreAuto("*")
// sauf entre Client et Commande
Client.DésactiveFiltreAuto(Commande)
 
/////////////////////////////
 
// Parcours des commandes
Commande.LitPremier(IDCommande)
TANTQUE Commande.EnDehors() = Faux
// Parcours les lignes de commande de la commande en cours
LigneCde.LitPremier(IDCommande)
TANTQUE LigneCde.EnDehors() = Faux
LigneCde.LitSuivant(IDCommande)
FIN
// Commande suivante
Commande.LitSuivant(IDCommande)
FIN
Syntaxe
<Résultat> = <Source>.DésactiveFiltreAuto(<Fichier de données à ne pas filtrer>)
<Résultat> : Booléen
  • Vrai si le filtre est désactivé,
  • Faux en cas d'erreur (fichier de données ou rubrique inexistant).
<Source> : Type correspondant à la source spécifiée
Nom du fichier de données utilisé pour le parcours.
<Fichier de données à ne pas filtrer> : Chaîne de caractères
  • Nom du fichier de données à ne pas filtrer lors d'un positionnement dans le fichier de données de parcours.
  • "*" pour désactiver tous les filtres automatiques possibles.
Composante : wd280hf.dll
Version minimum requise
  • Version 25
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire