PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE


WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget IOSApple WatchMac CatalystUniversal Windows 10 App
Autres
Procédures stockées
Annule le critère de recherche en cours. Le parcours du fichier de données peut alors se poursuivre à partir de l'enregistrement en cours, sans utiliser de critère de recherche. Les enregistrements parcourus ne correspondront pas nécessairement à la condition de recherche.
Remarque : L'enregistrement en cours a été sélectionné grâce aux fonctions de recherche (<Source>.LitRecherchePremier, <Source>.LitRechercheDernier, ...).
Exemple
// Recherche des clients à partir du client "Martin"
Client.LitRecherchePremier(Nom, "Martin")
SI Client.Trouve() = Vrai ALORS
// Elément trouvé : on annule la recherche
Client.AnnuleRecherche(Nom)
SI ErreurDétectée = Vrai ALORS
Erreur(HErreurInfo())
RETOUR
FIN
TANTQUE Client.EnDehors() = Faux
 // Traitement
 ...
 // Lecture du suivant sans utiliser le critère de recherche
 Client.LitSuivant(Nom)
 FIN
FIN
Syntaxe
<Résultat> = <Source>.AnnuleRecherche([<Rubrique>])
<Résultat> : Booléen
  • Vrai si l'opération a été réalisée,
  • Faux en cas de problème. La fonction HErreur permet d'identifier l'erreur.
<Source> : Type correspondant à la source spécifiée
Nom de la source sur laquelle le critère de recherche doit être annulé. Ce nom peut correspondre à :
  • un fichier de données (défini dans l'analyse).
  • une vue,
  • une requête.
<Rubrique> : Chaîne de caractères optionnelle
Nom de la rubrique du fichier de données sur laquelle le critère de recherche doit être annulé.
Si ce nom n'est pas spécifié, la fonction <Source>.AnnuleRecherche se réfère à la dernière rubrique du fichier de données utilisée.
Composante : wd280hf.dll
Version minimum requise
  • Version 25
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire