PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

PV

  • Limitations
  • Fonctions XML et threads
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget IOSApple WatchMac CatalystUniversal Windows 10 App
Autres
Procédures stockées
Exemple
clDoc est un xmlDocument = XMLOuvre(n, depuisChaîne)
c est un xpathRésultat = clDoc.ExécuteXPath("/root/text()")
SI c..EstValeur ALORS
Trace(c..Valeur)
SINON
POUR TOUT noeud DE c..Noeud
Trace("Noeud : " + noeud..Texte)
FIN
POUR TOUT attrib DE c..Attribut
Trace("Noeud : " + attrib..Nom)
FIN
FIN
Syntaxe
<Résultat> = <Document XML>.XMLExécuteXPath(<Texte de la requête XPath>)
<Résultat> : Variable de type xpathRésultat
Variable de type xpathRésultat contenant le résultat de la requête XPATH.
Lecture du résultat :
  • La propriété EstValeur permet de savoir si le résultat est une valeur.
  • Pour une requête de sélection (le résultat n'est pas une valeur), il est nécessaire de parcourir la variable xpathRésultat.
  • Pour une requête de calcul (le résultat est une valeur), la propriété Valeur permet de lire le résultat.
<Document XML> : Variable de type xmlDocument
Nom de la variable de type xmlDocument contenant le code XML à analyser.
<Texte de la requête XPath> : Chaîne de caractères
Texte de la requête XPath à exécuter.
Remarques

Limitations

  • Il n'est pas possible d'imbriquer plusieurs requêtes XPath de parcours.
  • Exécuter une requête XPATH sur un document XML :
    Les fonctions XMLSauvePosition et XMLRetourPosition ne permettent pas de sauver / restaurer une position lors du parcours du résultat d'une requête XPath de sélection.

Fonctions XML et threads

Si votre application utilise des threads, le document XML est partagé entre tous ces threads. Pour plus de détails sur la gestion des threads, consultez Gestion des threads.
Si la position courante dans un document XML est modifiée dans un thread, la position courante dans ce document XML est modifiée pour tous les threads.
Composante : wd280xml.dll
Version minimum requise
  • Version 24
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire