PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

PV

WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget IOSApple WatchMac CatalystUniversal Windows 10 App
Autres
Procédures stockées
Valide un document XML à partir d'un schéma XSD.
Exemple
// Validation à partir du schéma défini lors de la déclaration
cMonDoc est un xmlDocument, description = "schemaXSDDuProjet"
SI cMonDoc.DocumentValide() = Faux ALORS
Erreur(ErreurInfo())
SINON
Info("Le document XML est valide")
FIN
// Validation avec le schéma passé en paramètre
cMonDoc2 est un xmlDocument
SI cMonDoc2.DocumentValide("schemaXSDDuProjet") = Faux ALORS
Erreur(ErreurInfo())
SINON
Info("Le document XML est valide")
FIN
Syntaxe
<Résultat> = <Document XML>.DocumentValide([<Schéma XSD>])
<Résultat> : Booléen
  • Vrai si la validation est réussie,
  • Faux dans le cas contraire. En cas d'erreur, il est possible de connaître le libellé de l'erreur avec la fonction ErreurInfo.
<Document XML> : xmlDocument
Nom de la variable de type xmlDocument contenant le document à valider.
<Schéma XSD> : Chaîne de caractères optionnelle
Nom du schéma à utiliser pour valider le document XML.
  • Si ce paramètre est précisé, le schéma XSD indiqué est utilisé pour valider le document.
  • Si ce paramètre n'est pas précisé, le schéma indiqué au moment de la déclaration est utilisé (déclaration utilisant la syntaxe : cMonDoc est un xmlDocument, description="monXSD").
  • Si le schéma indiqué au moment de la déclaration n'est pas valide, une erreur WLangage est affichée.
Remarque : Si le document XML a été déclaré avec une description d'un schéma XSD, la validation est réalisée automatiquement au moment de la sauvegarde par la fonction <Variable xmlDocument>.Sauve.
Composante : wd280xml.dll
Version minimum requise
  • Version 24
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire