PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Présentation
  • Comment le faire ?
  • Méthode
  • Exemples
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Présentation
La version 23 intègre un parseur XML qui permet de manipuler les fichiers XML de plusieurs Gigas : par exemple, données de Open Street Map ou de Open Data France.
La vitesse de lecture et la consommation mémoire sont nettement améliorées sur les fichiers XML de taille importante. En effet, le fichier n'est pas chargé en mémoire : il est simplement parcouru.
Comment le faire ?

Méthode

Pour lire un fichier XML de taille importante avec le parseur XML :
  1. Ouvrez le fichier XML à lire avec la fonction XMLOuvreLecteur. Cette fonction permet d'initialiser une variable de type xmlLecteur.
    Par exemple :
    Lecteur est un xmlLecteur = XMLOuvreLecteur("MonFichier.xml")
  2. Parcourez le XML en utilisant une des syntaxes de POUR TOUT.
  3. Les propriétés de la variable xmlLecteur permettent de connaître les caractéristiques de l'élément lu.

Exemples

L'exemple ci-dessous présente un fichier xml didactique et différents modes de parcours avec la liste des éléments parcourus.
< ?xml version=1.0?>
<aa>
<bb>
Text1

<cc>
</cc>
</bb>
<bb>
<cc>
</cc>
</bb>
</aa>
// Parcours sur un niveau
// Lecteur est la variable correspondant au fichier XML
POUR TOUT Lecteur
// Lecture des balises début aa et fin aa
POUR TOUT Lecteur
// Lecture des balises début bb, fin bb, début bb, fin bb
POUR TOUT Lecteur
// Lecture de Text1 et des balises début cc, fin cc
// début cc, fin cc
FIN
FIN
FIN
// Lecteur est la variable correspondant au fichier XML
POUR TOUT Lecteur EN PROFONDEUR
// Lecture des balises début aa, début bb, text1, début cc, fin cc, fin bb, début bb,
// début cc, fin cc, fin bb, fin aa
FIN
Version minimum requise
  • Version 23
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire